Textures are not exporting with collada?

I have a simple cube with a material and i have uv mapped it to a texture. When i export to collada, and then import the collada back into blender, I see that the texture is missing, but he uv maps are fine. How can i properly export with texture to collada? Thanks.

The texture, .blend file and collada file are all in the same folder and i have used relative paths.

I am using blender 2.59.

THese are the steps i do…

  • create and save .blend file with crate.png in the same folder
  • add a cube
  • apply new blank material
  • go to edit mode and select all my cubes faces, then unwrap to uv map
  • in uv editor, i go to Image->Open image and open the crate.png
  • render it and it looks fine
  • Go to file->export->COLLADA and save to same folder
  • re-open blender and import->COLLADA, open ym file and see that the texture is missing in the uv editor…

Seems to work ok for me. When I import the .dae the textures are still located, even when I save the .dae in a different location to the image texture

What could i be doing wrong? i’m new to blender

Demo http://screencast.com/t/sUE4V32Y2wq

thanks for the guide, but I just followed it 3 times step by step, everything goes fine until in the last part where i import the collada back in, the texture is gone! even on the texture tab, theres not even a blank texture.

Also, your collada file is 17kb, mine is 10kb… and i followed exactly just using different textures

Tried your method again but with the texture in the same folder as the collada and .blend, now it works. Thanks for the help

I take advantage of this post to explain my problem…
I must export my planet earth in collada format…
So, I noticed that if I put the texture on the material properties, simply adding it in the texture tab, and then I export to collada, it won’t export the texture!
If I UVUnwrap the texture, it exports!
You can say: what’s the problem? Use the “texture UVmapping mode” and export to collada!
But…if I use the “Unwrap-mode” I obtain a non-perfect texturing of the earth…I tried in many ways (Sphere projection, Cube projection, Cylinder projection, etc) but the result it’s not like texturing in “basic-mode”!
Infact, putting the texture simply on the material, and selecting:
Coordinates: Generated
Projection: Sphere
I obtain a perfect texturing!
So…how I get out? :confused:

p.s.: I use blender 2.59

Most likely the exporter will only take UV mapped textures as any other software will then know how to apply the texture.
You will have to change your existing texture from generated coordinates to UV coordinates. UV unwrap your sphere, create a new blank texture then bake the original texture to your new blank one from the Render / Bake panel http://wiki.blender.org/index.php/Doc:2.5/Manual/Render/Bake

Ok…I tried…

First I set:
Coordinates: UV
Projection: Flat (right?)

Then I add a new blank texture in the UV editor…it must be of the same dimensions of the original texture?

Selected the sphere, unwrapped it.

In the Bake section (in the render tab) I set:
Bake mode: Textures (right?)
I leave other settings default and then press Bake.

After a few I obtain the new texture in the UV editor…
Now? It seems identic to the original! What I must do?
If I try to Unwrap > Sphere projection, I obtain the same bad result!
I’ve done all in the right way?

Sorry but I’m new to this world! :slight_smile:

Demo of baking a texture to new UV coordinates http://screencast.com/t/9OtYkQhUhpT

Thank you for the screencast…
but I still don’t understand how to do a perfect UV mapping…
Here is what I make: http://screencast.com/t/yzVEB0sG8

If you can see, when I simply texture, the (auto)mapping is correct (see the north pole)…
when I UV-map, the mapping is not good (the north pole is distorted).
I’m doing something wrong?

No one can help me? :mad:

Try unwrapping with a method that doesn’t lead to distortion. There are many ways to unwrap a sphere, the simplest is to select the vertices around the equator, Ctrl+E / mark seam. Then select all vertices and U / unwrap. This will give the unwrap as two circles, one each for the north and south hemispheres. Then bake the texture.

Thank you Richard! I solved! :smiley:

Thanks so much for this thread.
I have been looking all over for info on how to export with Collada _> Torque 3D
Coordinates: UV – I had not seen that at all! I was always worried to set TextFace. object dropped in great!

anyone know how to set collision up?

perhaps a working simple object with a simple texture with collision in .blend format they would be willing to share?

it shows my object and the collision mesh without even putting empties or a bounds box.

thanks for the testure and the UV bake vids! shweet!!

thanks in advanced for any other help.

Hey

I’m also new to blender and I’m also experiencing problems exporting textures using Collada format.

I’ve tried all the solutions you guys posted here, but nothing works.
Here’s a video of how I’m doing things: http://youtu.be/gIxLHvKZ5Iw

As you can see, I can’t even get the texture mapping to work correctly, even though the UV editor clearly shows that the mapping is set up correctly and all sides of the cube should be textured.

The second issue is with the exporter - it saves the UV mapping, but doesn’t persist any information about a texture the cube material references.

Could someone please help me understand what am I doing wrong here?
I need to mention that I’m using the latest Blender build ( 2.63a ).

Thanks in advance :slight_smile:

Check the name of the UV Map. You may need to reselect the correct UVs in the Texture / Mapping panel. Having the texture in the UV image editor window is of little importance for rendering the object, the material and the texture applied to the material does.

Thanks for the response. How do I check that? I’m also new to Blender. Could you tell if it’s set by looking at the video I posted?

I think I understand what’s going on - Collada exporter apparently can’t handle multiple textures.

The way I was testing it was using the sample scene - but that sample box that’s in it right from the start already has a material with a single empty texture assigned. So when I was assigning it a new texture, what I was really doing was creating a second texture.

I saw the “Tex” entry on the textures list, but since there was no icon next to it etc. and it was therefrom the beginning, I though it was just a header or something - noob’s mistake.

Anyway - that single texture thing is kinda not what I was hoping for. I’m looking for an exporter and a format that can handle:

  • geometry ( obviously )
  • basic material settings ( basic colors + specular falloff value )
  • at least 3 textures ( diffuse, bump, specular )
  • can export animation as well

I thought Collada would be able to handle it, since the format IS very flexible, but apparently the exporter implementation isn’t.

Can you guys recommend something? And prefereably something that exports to a format that’s well documented ( I’m writing an import pipeline for my game engine and I need to import from some files ). Eventually I’ll just write one in Python, but I was kinda hoping to take advantage of an existing one.

Thanks in advance :slight_smile: