Textures being stretched

I made a plane, and added a texture to it. But the texture is stretched so much I only see vertical lines. How do I fix this?

Screenshot? but my guess would be play with the X,Y,Z sizes or the Z,Y repeat. Other than that I’m clueless.

Actually, maybe not horizontal lines, but its tilted and zoomed in really far. I think it’s just showing the top left corner in the screenshot. The first attatchment is the texture (a render of the same project, but different frame), the second is the actual render.

Attachments



If I click the Win button under Map Input, it renders the image correctly except slightly enlarged. If this helps.

And here are my settings.

Attachments


Now I know what’s wrong, still don’t know how to fix it. When I first create a plane, and it’s flat, the texture displays fine. But when I rotate it so it’s stand upright, the texture is stretched like that. So I think that the texture is mapping to the planes original position. Any help? I must be doing something wrong.

In the Map Input panel (default is a tab on the texture panel in Materials buttons) there are a number of buttons that control how the texture is mapped to the object being textured, with obscure names like Glob, Orco (the default), Win, Stress, Tangent, Stick, and so on. Check out the tooltips on each of these, it could be the fix to your problem.