Textures imported incorrectly and shown pink with <UDIM> in title

Hey everyone. I’m having trouble using Textures exported from Substance Painter, even though I’ve done this many times before and it always seemed to work.

The problem is that whenever I add an Image Texture node inside of the Shader editor and import a texture, blender automatically adds to the name (like

Colt<UDIM>_Colt1911_BaseColor.png

for example) and the texture on the model is shown pink / missing. For some reason, this only happens with some images, but I can’ really figure out what the reason for that is.

It also automatically sets the source to ‘UDIM tiles’ instead of ‘Single Image’, but changing that doesn’t seem to make a difference.

If anyone knows how to tell Blender to import Textures correctly, please let me know, any help would be greatly appreciated!

(I also attached the texture I was trying to import in case that helps)

Welcome :tada:,
The 1911 is for a year of the colt ?? Maybe Blender is just misinterpreting it for another UDIM info… try to rename to just colt…

According to docs blender manual udims:


Examples:
  • monster-basecolor.<UDIM>.png will load/save files like monster-basecolor.1021.png etc.
  • monster-basecolor.<UVTILE>.png will load/save files like monster-basecolor.u1_v3.png etc.

So you double Colt1911_ interfere with UDIM detection…

Turn off the UDIM option when importing the image:

1 Like

Oh yes :person_facepalming: … i thought @Coxcopi was using UDIM also… (maybe because of Subst…P… ?).

1 Like

Yes, 1911 was the name of the colt. Thanks @Thatimster, turning off ‘Detect UDIMs’ works perfectly!

1 Like