Textures in editor?

Seems like I’ve seen many examples where the editor displays textures, but there doesn’t seem to be a way to turn it on or off. I saw a mention of a bug with UV maps and Image file texture types, but nothing seems to work. I am using the textured view. Renders show the texture but if possible it’d make things easier for me if the editor would display something.

procedural textures [the texture buttons, clouds, veroni, marble…] can’t be displayed in the 3d view, shaded mode shows them as colors applied to the verticies of an object [which is intended as only a preview, it isn’t updated during an animation]

images applied via uv mapping show up in textured view mode [alt+z]

the terminology can be pretty confusing, there is an image texture in the texture buttons, but that can [depends on the mapping coordinates you choose] be completely different from applying an image by uv mapping

I am using an image texture in the following image, when I switch to textured mode it looks a lot like solid mode. I also included a screenshot of the render but it don’t look as intended but shows that a texture is there. I have screenies of the solid shaded and textured mode.

Click for full size.

shaded mode shows them as colors applied to the verticies of an object

Thus you can view your texture if you subdivide a lot. Your model is pretty lowpoly so you only see one or two colors. I don’t recommend unnecessary subdividing. So to view textures in the 3D-view you should uv-map. Why would you want to show them that way anyway?

Why would you want to show them that way anyway?

Not sure what you mean with the question but here’s my answer to what I think you meant…

I think the main reason I want to be able to see the textures in the 3d editting window is so I can easily view the various angles, instead of having to move a camera to a position I want. I suppose if the yafray editor allows me to rotate an object that’s rendered so I can see it from all sides with textures easily I wouldn’t care much about what the editor shows though it seems like it should. I have a UV textured tank I made (low poly of course cause I’m a programmer, not a modelling god and I’ll likely want everything to be low poly anyway for my games). The UV mapped tank shows as all white in the texture view in the editor, possibly cause I played with material settings more there but not sure about that.

Has anyone answered my question about being able to see textures in the editor without rendering, just want to make sure someone didn’t say it was impossible and me not just understand it. My UV mapped model shows up as all white in the editor in texture mode, though it displays correctly in all it’s amaturish glory in the render window fine.

I’m sorry, but I don’t really understand your problem. You’d like to apply textures and view them without rendering, otherwise you’re not able to view your model correctly because it’s all white in textured view. Then why don’t you use solid view instead?

Whether it is possible to preview mapped image textures in the 3d view depends on the OpenGL drivers and your graphics card.
AFAIK the OpenGL system can only use images with square numbers as height and width, for example 64x64, 128x128, 512x512.
Modern graphics cards also support 1024x1024 pixel images.

So if you have a UV-mapped texture with one of these dimensions it should show in the 3D-view in textured mode. Else it could be an OpenGL driver bug.

I could mabe also depend on the graphics format… Though i don’t know which will work for sure… Try *.tga

in face select mode with your faces selected on your uvmapped model, select in the image window the texture you want applied… if this doesn’t work then wah_tak is probably correct that your graphics card doesn’t like that texture size.

oh, wah_tak, if you can load an image type you can apply it to something
blender supports: png tga psd [through quicktime] iff [weird format, don’t know much about it] jpeg bmp…

You left out 256x256 sized images (which is the size of the image I used originally). I might have given in to the weird insistance blender has for wanting to make 500x500 pictures by default for uvmaps instead of telling it to make a power of 2 map, I double checked it by making a cube and setting textures to it (also tried a uv map). The textures didn’t change the appearance at all in the editor though uv mapping changed the object to all white. I have an x700 ati card, though it’s been a few months since I checked my drivers so maybe I’ll get lucky.

Egg: I know how to see my model, I just can’t see my model with a texture applied, so it’s more difficult to make adjustments to the texture settings.