Textures in .exe?

Ok for some reason i made a .exe in 2.42a with textures packed and the textures didnt show up in the .exe i tried it both using blender matirals and without but still doesnt work

any suggestions?

thanks,

I think you must include all resources…

I am not sure, but if I am not misstaken, you cant pack the textures into the EXE…

I may be wrong about this though…

i got the same excat thing with mine.

Yea it used to work with previous versions of blender but some reason not with this one, so looks like the soloution is to pack them into the game folder in thier own “Texture” folder.

hmm… works fine for me. I don’t know what to say. I’m using 2.42a, and textures pack nicely in the runtime.

Try disabling “Use Blender Materials”.

i have tried it without blender mats but still no :frowning:

I’m having the same problem and more. This is my first time compiling to an EXE. my game runs great hitting “P” from within blender (all python scripts work great, my UV textures, my lighting, animations, cameras, and my external code)

  1. My UV-mapped textures don’t work (I did use “pack data” and save, tried with and without “Blender Materials” on).

  2. Anything I’ve writtin in python for the game engine isn’t running at all, only pure logic bricks. (I have copied my DLLs and all into the runtime folder)

  3. My camera is ignored, viewpoint is the same exact spot in every scene, doesn’t change even when I move the camera.

Any help on this is appreciated.

ooookay I figured out problems 1 and 2, but I’m still having problem 3.

my problem for #2 is I had forgotten I was using “Registry” in the blender module to save variable information so that it would persist and the scripts were crashing. I was intending on finding a workaround before compiling it and had forgotten about it. Now I’ve reached the point where I need the workaround. How can I keep persistant data?

the solution to #1…was that BGE apparently doesn’t support .gif images. All I did was change the images to png format.

Ahh yea they were .gif witch the .exe doesnt support, thanks amoore!