Textures in renders

Hey iv been using blender for a while now and now a lot of stuff but i just started learning texturing today and i cant find a way to put the textures in the render
In the Draw type: Textured i can see it though…

Hey, I’m having the same problem. All textures were working fine, until a little while ago. I didn’t notice it at first so I’m not sure when it happened and what I did to cause it. Anybody have any suggestions?


Thanks for the URL. I couldn’t really find anything explaining this problem though. Its like we turned the “Render textures” button off somewhere… Anybody have some more suggestions?

I think you are having a different problem than the OP

the link will explain how to map the textures to the objects a number of different ways

but with your problem - you may have pressed the “Disable Tex” in the render buttons

but also check you have them mapped to the object correctly

There is a disable textures button on one of the Render panels.

Oh wow! There really is a disable tex button. Unfortunately, that wasn’t the problem. I narrowed it down to a UV mapping problem. I’m trying to use an image as a texture using the UV coordinates (because I unwrapped the sucker and made the image using that template, of course). So under map input I selected UV instead of orco. When it’s set to orco, it shows up fine, but as soon as I select UV, the texture dissapears. So its something to do with my UV coordinates right? I can’t figure out what though, when I display them ontop of my image texture, everything lines up?

Any suggestions here? Thanks!

When I go to UV map and bake images to meshes, my method is to go into the UV image editor and open up a completely new image (this image is blender generated, not loaded from the hard disk and is usually black.) and name it ‘textures’ or something relative. Next in the edit panel, I select the UVTex slot that has appeared because I created a new image in the UV/Image Editor, and rename that to ‘Textures’. Next, I go back to the materials panel and click on my texture, and go to the map input tab. From there I click UV and typee in the name of the UV texture I want it applied to. Finallly after you have the UV texture set up, select your mesh, tab into edit mode, and unwrap it. That’s basically it. (From there you can choose to bake the image to your mesh but that is a little bit more complicated. If you want more info on that subject, let me know.)

i thnk you alos need to load up a picture in UV editor to see it there!
the picture you load in F6 is the UVmap but you don’t see it in UV editor


Thanks a lot guys! Lunatic, I tried ding what you said and it didn’t work for me. maybe I did something wrong though. What I’ve done is unwrapped my mesh, then using that as a template, made an image to use as a texture. I took that image and loaded it into the UV image editor and then I went into the material tab and added a new image texture using the image I just made. I think all I did after that was fiddle with the colour band and then I went to the map to tab and selected UV, leaving the UV slot blank because there was only one layer.

Oookk, I think I fixed it. My problem was mainly just disorganization. Too many textures and materials, all with basically the same name. Thanks for the help guys!