Textures in Viewport !?

Hi, i have never ever manged to keep textures visible in viewport and most of the time i am not even sure how to have them visible in the viewport! I’ve been watching many tutorials but most seems to be for older Blender versions and some things do not match ! Using “Blender Render” i am having a black materials only when switch to material display method. No even colors are visible ! Adding texture to material does not help. Switch shading to GLSL or Multimaterial does not help as well. Always get white or black objects in viewport !!!

I am really confused with the material/texture setup in Blender ( i am coming from 3ds max ) !

So can someone who knows, please explain what is the proper way of adding a texture to blender and have this visible in the viewport. One thing if i load a texture from the UV editor i can see it in the viewport. Should a texture be applied only from the uv editor, and one of the biggest things is if i press “Shift + Z” to enter rendering mode and have been in texture display mode, pressing “Shift + Z” again returns to solid mode and not to the last display mode which was the texture display…

Totally confused about whole material/texture workflow !

Some quick tips or best practices to create and apply materials to objects ( to be used in games ) would be really helpful !

Well and another thing that is super strange to me - why if a texture is applied to some polygons from the UV editor, when you export to FBX to let’s say Unity engine, a material using the name of the texture rather then the name of the material applied to the object is created … !!!

NOTE : Been using Blender for a couple of years, but that workflow is still confusing me ! Using Blender 2.79 .

By default the textured viewport shading mode shows face assigned textures, which are images assigned to UV faces either in UV/Image editor, or by dragging and dropping an image on the model. This is used for UV layout work, baking, and for texture painting.

Material viewport shading mode shows material assigned image textures and shading. The scene needs a light source, or the material needs to be shadeless. This is same as setting textured viewport shading mode to use glsl, which is kinda redundant.

Switching render engine to Cycles also changes viewport behaviour. The material systems between the two aren’t compatible, and in Cycles the textured viewport shading shows the selected texture node, and material viewport shading tries to show a preview of the node setup but fails with complex materials.


Here is my workflow when modelling for a Unity game.
A - Create and assign materials (each material has to have a texture file loaded). Next, I select faces in the viewport and with desired material selected, click Assign. In my example grass material is assigned to upper three faces. I did the same for bottom part faces but this time I selected Rock material and clicked Assign. If you are using Solid shading for Viewport, you may not see textures yet. Then comes step B.

B - UV Editing - With cursor inside Viewport I selected three upper grass faces and unwrapped them. In this case I just used Reset. Then I moved my cursor back to UV window (left part) and pressed CTRL+A to select all UVs. With UVs selected I then clicked the image icon that lists all the texture files loaded in the Blender file. Since it’s upper three faces unwrapped that means I want grass so I selected grass texture file (one that you also use when creating grass material in step A). I did the same with bottom rock part and used the rock texture file. This B, UV Editing step is similar to A step but here you assign TEXTURE FILES to faces instead of MATERIALS.

C - Viewport Render preview which proves that materials are assigned properly to faces.

D - Viewport Solid preview which proves that UVs and textures are assigned properly to faces.

Ok, the lack of light in the scene was the reason of displaying black objects. I thought there is some ambient light available by default, i don’t know why ! So thanks about that !

I just wonder if you know how to set up Blender to return to the last Display Method when switch to “Rendered” mode using “Shift + Z”. It always returns to solid after quit the Rendered !

It’s the default behaviour. Pressing shift+Z again returns to the viewmode previously selected.

Strange, in all versions i used it goes back always to solid mode ! Will search the internet, thanks again !

The way I checked that it’s the default and not my own change was by loading factory settings from the file menu, and then testing it in both Blender Render and Cycles viewports.

Blender 2.79 on Linux, 5bd8ac9abfa. If there is a platform difference with the default behaviour, I’m not aware of that.

It was always the same even on pre 2.78 for me. I did try a factory Reset on 2.78 and 2.79 now. Still get the same result - it always returns to Solid mode.
I thought it is a limitation which is not addressed yet but might be platform specific bug or something else then !

Will keep searching for a fix. Thanks for all the answers !