Textures look worse in material preview than in texture paint tab solid view

Hello!

I was working on creating a skin texture for one of my characters, but the skin texture looks far better when I’m in the texture tab and have selected the solid viewport than when I have the material preview viewport selected. I’m not sure if this is a problem with the settings I have in the Shader Editor, but I have had no luck when trying to change settings in the Shader Editor. Here are some images so you know what I’m talking about:

Thank you so much!

The specular is low and the roughness is high so we don’t have much specular in material preview.