Textures lost in Cycles

Textures, that are used in Cycles shader’s structure are shown correctly in “Material” mode and are lost when rendering. This started when I packed files into .blend and moved .blend to another directory. Now I have to reassign textures one by one and delete duplicates. What I’m doing incorrectly?

Cycles cannot currently use packed textures. Unpack them.
From the wiki: http://wiki.blender.org/index.php/Doc:2.6/Manual/Render/Cycles/Nodes/Textures

Currently not all images supported by Blender can be used by Cycles. In particular generated, packed images or animations are not supported currently

Thank you. I’ll try.

you need to unpack texture into new folder !


Related query…

I have, too, packed images into cycles for them not to work again when the file is moved…

I have subsequently unpacked the images, and I still get no joy…I Shift+Clicked to completly remove them and saved then reopened the file, re-applied the images and I still get no texture…

The original model was created in Blender 2.60 and I am re-openning in Blender 2.61.

However If I re-open in 2.60 it will except and apply the images…!!

Are 2.60 files not compatible with Blender 2.61 or above?

Are 2.60 files not compatible with Blender 2.61 or above?
I am not absolutely sure, but i remember some work related to how texture mapping nodes work, and many new nodes added. You can test it recreating some objects from scratch with same file.

If you use some experimental fancy build from graphicall.org than is can be worse, for example volume patch screw internal node structure and any scene saved with that build will not work in later version up to completely data loss.

Admittedly, both 2.60 and 2.61 were from graphicall, but from the same builder…still I’d imagine some issues would be apparent…

What is the general feeling about builds from graphicall?? best to stick with the blender.org releases or do the graphicall builds have merit?

Just tried a model created in a blender.org version of 2.60 and opened it in the latest blender.org version of 2.62 and still no textures…

seems like they may not be compatible…does this mean i have to have multiple versions of Blender installed depending on which model I work on??

Anyone clued up on how to overcome this anomaily?

Admittedly, both 2.60 and 2.61 were from graphicall

It depend. Some builds are very close to trunk with tiny changes, some bleeding edge experimental. It nor related do you use same builder or not, as i already note Volumetric builds DO destroy your data even they from same builder (I do it intentional to keep priority to base core blender data instead of experimental nodes). Some blender changes are safe, other not. Blender have very cool RNA/DNA system that trying to do best and provide compatibility even if large parts if inner data change, but not in any possible cases. Official Blender builds and graphicall builds close to that of course have much better quality related to compatibility.

Anyway, it just my guessing, i not sure what exactly make your scene bug. Maybe your latest binary packed with 3th library like png/jpeg that changed and cannot open some old files?

can you upload file with pack 2 textures so we can test it

and are you on windows?

never seen this problem before !

but you need to unpack the texture first in the folder where the file is located
and it should work fine
at worst you may have to manually re upload the files but should work ok !


Having issues uploading from work…

Will upload when I get home in 2 hours…

Stupid work internet blocker thingy…

try to zip it may be !
and don’t forget to pack your file when saving it it will help

if bigger then 1.5 MB try at pastall


Images packed…created with Blender 2.60

Please excuse the modelling, I’m still learning!!

Couldn’t get it to upload on here so follow the link below:


Trying to upload image but no joy…what am I doing wrong??..

tried to remove the world
and still very bright

ho can you reduce this brightness?


ok don’t know why

but just go to the nodes editor for each mat with image texture

remove the image texture node
then add node texture image texture and reload the file from the node editor
then it works fine !

let me know


I’ll give that ago…I’ll report back…

Many thanks for taking the time to look…

Perfect…that did the trick…

Problem, what if you have a model/scene with a whole bunch of textures…it would be a massive task to edit the material nodes of all meshes…!!

I don’t suppose anyone knows a way around this??

Rickyblender…many, many thanks for your time and very kind solution…

may be open a new thread for a more meaningfull name for it

someone else might find a more elegant solution


at worst you could sent your file as a bug report and give this thread as a reference may be
and see what answer you get from Bretch
he is the master dev for Cycles!

nothing to loose i guess

i could also be a know bug may be!


I’m experiencing a similar problem where textures are being lost. They are in the texture node correctly but I have to reload them when I open the .blender file again.