Textures not appearing properly in standalone player

If I hit P inside the 3D view everything looks fine. If I run the standalone player however, so I can view in fullscreen, everything seems “mostly” alright except that my texture images seem to be flipped. I can see through the mesh to the inside wall of the opposite side.

I can post a .blend so you guys can take a gander if need be. Although, I tried to transfer to a different computer earlier and noticed the textures didn’t stay with the .blend. Is there something I need to set for the textures to be part of the blend file, or do I need to keep all the relative paths in a directory when I’m transferring a project? <-- answer if needed.

EDIT:
No one seems to have an answer, so here’s 2 screenshots to help. The first is just hitting P in the 3D view, and the other is a fullscreen standalone player.




Thanks!

Did you pack the ships texture? If not select the ship in object mode, click materials button, select ships material, click textures button, under the directory field or path for the image (C:…\shipimage.png) there is a little button with a small sandbox icon (or something).

You might have to re-setup the image. After its been opened in the texture interface, you should get that icon.

Click it and a little piece of paper will be in the box. Its now “packed”

Now, before you export your runtime, goto File, External Data > “pack into .blend file”.

That should work if I’m not mistaken.

Oh wow. My bad. I didn’t realize how misleading the pictures would be. The ship doesn’t have a texture. It’s the asteroids. Look at them real close and you’ll see that they’re being cut off or something. Or all the faces are pressed together… I dont even know. But yea, sorry. The issue is with the asteroid textures. I have another post about textures as well that is similar. Textures dont seem to like me.

Ok, I examined it a bit further. Here’s some video of the asteroids in the standalone player. It looks like the textures caved in on themselves while the collision mesh is still intact.

If anyone has any idea and can help that would be great. I’m at a loss.

That… looks… VERY strange. Can you show a wireframe of the asteroid mesh? Is it one object?

HAHA! Oh, silly me. Thank you for asking for a wire frame. I went into edit more, pulled up the wireframe and noticed it was a perfect egg shape. I then realized I had not applied any of my displacement or subdivision surface modifiers. All is now well. The standalone player clearly has NO idea how to handle modifiers.