textures not showing up in 3d window

Hi all, I’ve got this weird problem.

If I were to do a UV unwrap, the texture shows up on the model in the 3d window. If I were to just map a texture to a model using Orco or UV, it does not show up in the 3d window!!
Only thing I note is that the model gets slightly darker.

In both cases they will show up on render.

Some things I have done to eliminate possibilities:-

*Texture Draw-Type was selected in 3D window
*Was not (extremely) frustrated.

Thank you in advance!

If you use an image mapped to UV in the image editor only, you’ll need to press ‘texface’ in the F5 shader panel to allow the uv image to show in the 3d view. If you are using a procedural texture mapped to uv, it will not show in the 3d view. That might be why you see the black material.

If you want to see procedural in the 3D view, you can set the display to shaded and then subdivide the hell out of your mesh. The procedural texture will effect the vertex color in shaded mode.

No the texture is just an image file - not procedural. I tried the texface thing but still didn’t happen. Would you please take a look at the file, I have packed in the image texture as well. www.3dguys.org/uploads/bricks.blend thank you very much for your time and mostly, your patience!

No the texture is just an image file - not procedural. I tried the texface thing but still didn’t happen. Would you please take a look at the file, I have packed in the image texture as well. www.3dguys.org/uploads/bricks.blend thank you very much for your time and mostly, your patience!

No the texture is just an image file - not procedural. I tried the texface thing but still didn’t happen. Would you please take a look at the file, I have packed in the image texture as well. www.3dguys.org/uploads/bricks.blend thank you very much for your time and mostly, your patience!

thanks guys for the input, however it’s still not happening. A sample file I was working on is at 3dguys(dot)org/uploads/bricks(dot)blend

Would anyone look at this file and tell me where I went wrong? I have packed the image file in. Thanks!

Yes, like I said before, if you haven’t unwrapped your mesh and set the image to uv in your material, it won’t show. If you at least set your material to ‘texface’ and uv unwrap your mesh to the image editor with the image open, you will then see it in the 3d view.

I got yours to show by setting the second 3d view to image editor, and pressing ‘U’ to unwrap and opening the brick image in the editor. Immediately the texxture showed on all faces, but the orientation is up to you to decide.

Attachments


OH IS THAT HOW IT WORKS??!!! Haha sorry i must have my head still stuck in 3dsmax.

Thanks Craig you have saved me twice :slight_smile:

My object is UV’d, I’ve got it set up to render with the image, it shows up for texture painting but I can’t see it while in edit mode. So fixing my UV’s is impossible.

Have you got your draw mode for your 3d window set to ‘textured’? If not, you won’t see it, as well as make sure you have it set to ‘texface’ in your material panel.

It is on shaded and texface.

Blender 2.47

Try ‘Textured’ instead of ‘shaded’. It is the topmost choice in the draw modes.

Even textured does nothing.

How about a blend with your imaged packed in the file? Go advanced on your reply and add the blend in the ‘manage attachments’ here and I’ll take a look at it to see if I can ferret out the cause of your problem.

If not soon, at least by the time I get home today, around 2 hours. Or someone else will beat me to it :slight_smile:

I am also having a hard time rigging it, but that problem is for another forum. :wink:
http://www.seanjmacisaac.com/WIP/Uben/Uben_Rig_013.blend.zip

There’s the zip.

Thanks for your help!

Really nice modeling there. I can’t find the fault except fro when I use Shift-P to preview render, I find there exists a low poly version in the same space as the uv mapped version.
Also, there are two layers open, one marked UV and the other Vert Color… I’m not familiar with the use of both at the same time.

Something seems to cancel out your map. I will keep trying.

The low poly version is the control mesh for the rig. I didn’t turn off it’s renderability.

Thanks for the compliment on the modeling.

If you use Apricot GLSL, you can see all material-mapped image textures (not procedural)

B3D00: Try my file out, while unwrapping the model, with texture enabled for shading type I should be able to see my model update the texture coords so I can be sure I have a good map.

But for some reason it is not working.