textures not showing up

i have created my scene with textures applied to objects…but when i append this blend file to other file the textures doesn’t show up. i appended objects,materials and images but it dowesn’t work.
how to properly append the files so my textures also appear??

You either have to turn on glsl/textured faces in viewport or have to move textures so their relative directory matches the one in the file you are appending from.