Textures not tranferring to runtime

Okay…so i’ve made my game…packed my textures into the appropriate folder…but when i run the game…the textures are the same as if i just pressed ‘P’ in blender :frowning: (only the shading…no actual textures) how do i get my textures to show up in my runtime? :confused:


Are you sure you clicked on Pack Data ?

im pretty sure…it created a folder called textures with all the jpgs in it…is there something else i was supposed to do?


In Blender, in the main File menu (where you open and save your .blends) there is an option called “Pack Data”. You need to click that in order for your textures to be included. Also, you should be able to see your textures in Blender when you press the [P] button. You need to be in “Textured Solid” draw mode (press [Alt+Z]).

You need to click on Pack Data in blender like blendenzo Said. If you dont do that it wont pack the textures even if you have them all in the same folder.

i did do that and it still dosn’t work…so i decided to unpack it…and chose unpack to current location or something like that…and then i hit Pack again…its still isn’t showing up…im in textured mode too :-…
i must still be missing something…sorry guys


Hmmm… That’s Wierd What version of blender you using I am just wondering ? Sorry if it takes a while for me to reply I am watching The Simpsons =)

Hmm… well, there are a couple questions that come to my mind. First, did you apply the textures using UV mapping, or did you apply them through the textures subcontext of the shading buttons? Second, if you applied them through the textures buttons, do you have “Use Blender Materials” turned on in the main “Games” menu?

You can only “use Blender materials” if you graphics card supports OpenGL (mine does not, so I UV map everything).

If you did UV map the textures using UV Face Select Mode and you are still having this problem, I suggest that you pack each texture individually via the UV Editor window instead of using the File menu function.

i’m using Beldner 2.37a…

i didn’t UV map…but there is no 'use blender materials in the game menu (i’m assuming you mean the “game” button on the taskbar)…so i guess i have to UV Map everything :-\


Yeah. You are going to have to UV map everything. “Use Blender Materials” is only available in 2.41 and later. UV mapping is the only way that textures will show up in the Game Engine in 2.37a. If you need or are interested in a tutorial on UV Mapping, I recommend this one that I found in the Tutorials Sticky.

allright…thanks so much for your help guys…


ahh new problem…so i went to download (did download) blender 2.42…and when i went to play my game…the characters just floated away…any different sort of setting between the two that i need to change?


2.42 has some major changes, including a completely different physic system. Games made in 2.41 and earlier versions are pretty much incompatible with 2.42, so if you started it in a pre 2.42 version under sumo physics, I suggest you finish it in a pre 2.42 version.