Textures with alphas, transparent areas showing up as black in 3D Viewport in 2.71

I’ve come across this issue in multiple files created in 2.71 and using a file I had started in 2.70 (and worked correctly in that version), in the 3D viewport projected textures with alphas, the transparent areas appear as black. These textures render correctly (as transparent), but show up incorrectly in the viewport. Here is an example file altuve_swing_v003.blend (1.03 MB), you can see if you render that the alpha is working correctly.

That test file works fine with me? buildbot version e0d8e62 (2.71)

have you tried viewing it under glsl mode?

I tried glsl mode, same result. On the test file are you seeing the entire image plane as black? Cause the only thing that should be visible is a small dark area in the top middle shaped similar to florida (probably not the best example). Currently my only workaround is to run it in 2.70a. This is what it should look like:

Your file has shading multitexture, not GLSL. Works here with Official 2.71 Win64bit Win7.


That is the version I’m using, but this is the result I get:
actual screen shot:

If I render active viewport:

Try another alpha image, maybe your image is corrupted or something.

Works fine here, too, in GLSL mode… (Blender 2.71 x64 “official” / Win 7 x64)

Did you try updating your graphics drivers?
Seems Blender 2.71 changed the “communication” between software and the graphics hardware in some ways. There were several error reports in this forums (concerning different areas of Blender) from users switching from 2.70a to 2.71 - that in the end could be solved by “just” updating to more current graphics drivers.