Texturing a Hole


(DAK) #1

I would like to make a hole in my object. I made a B&W texture to use as an alpha map, but it just refuses to make a hole. Now, if I turn the global transparency down, it makes the ENTIRE object transparent! There MUST be a way to use a texture to just make a decal area of an object transparent.
I’ve tried inverting and this is still not working. Only time I get transparency is with the global trans option lowered :frowning:


(_Aorus_) #2

Make sure that the Alpha button in the materials menu is pressed and lower the alpha of the material to 0. Then you should get a hole. In the texture menu also make sure to have the Use Alpha button pressed. I’m not sure if the Calc Alpha and Neg Alpha are necessary but u can play around with those and see what happens.


(Jolly Gnome) #3

nope, the UseAlpha, the CalcAlpha and the NegAlpha aren’t necessary.
Press the “Ztransp” and “Alpha” down in the materials menu, and slide the Alpha-slider all the way to left.
(I’d try that myself right now, as I’m doing this out of memory, but the Blender just crashed, and I need to reboot before it’ll start again)


(DAK) #4

The use-alpha is for alpha channels. I do not see how this is related to making part of the object transparent.

In any case, I have used Ztransp, and pressed the Alpha buttons in materials, with the alpha slider all the way down. And this is what is precisely causing the problem as I mentioned. Either I get the entire object to disapear, or not. But I can never get the texture to effect a hole. Transparent slider seems to only work for global things :frowning:
I am trying to place my texture like a decal, and make part of the object disapear over the decal.


(IamInnocent) #5

Here’s an example :

the image_map I made : http://pages.infinit.net/bobois/alpha_map.jpg
the texture settings : http://pages.infinit.net/bobois/alpha_texture_settings.jpg
the material settings : http://pages.infinit.net/bobois/alpha_material_settings.jpg

the result : http://pages.infinit.net/bobois/transparence.jpg


(DAK) #6

I did this before and didnt’ get the same results:( Maybe it’s due to the fact that I am using an empty to place the decal and not sticking with orco. I will test for this bug after posting this.


(digitalSlav) #7

haha just thought i would pass on a little funny :c) sitting here with two women playing sexual trivia and the first thing on the forum is “texturing a hole” LMAO… time to catch my breathe…


(IamInnocent) #8

Here I made my answer as a mini-tute with some complementary explanations that one may find useful.

http://membres.lycos.fr/bobois/Tuts/trouer_par_texture/trouer_par_texture.html


(DAK) #9

That Dvar slider is a new command I never seen it anywhere else, but very interesting. I used your technique to use this method to make a hole on a plane and it works, unfortunately if I have a complex mesh object, and place the hole with an empty, the texture just refuses to work properly, and once again starts to do bizzar things like making the entire mesh invisible again!


(IamInnocent) #10

I’d love a little drawing, an image here, anything.

I’ll attempt a guess : is that something like this that you want ?
http://membres.lycos.fr/bobois/trou_uvmappe.jpg


(DAK) #11

I tried your technique many times in many different situations. It works, except on this one mesh I had made. I believe I am a victim to another blendber bug. I currently found a way around it however.
Unfortunately, I re-discovered an old problem with blender aliasing. The Z-buffering makes aliasing 10x worse. Toggle between buffers and see this for yourself. Now if I could only find a way around THAT as well :frowning:


(IamInnocent) #12

DAK,

until now we have used the “lowtech” approach that makes do without a real alpha channel, using only the R, G and B values for calculations. What about drawing your mask in the Gimp as a TGA with real alpha and the check the use alpha button in the texture buttons (F6) ? Your peculiar mesh might like it better…


(Briggs) #13

DAK,

If you would email me the blend that is giving you trouble I would like to take a look at it and see if I can offer any suggestions. [email protected] (If you could zip it up that would be great).


(DAK) #14

Ok guys I will try playing with gimp and alpha for making a hole in a mesh. But my old problem still stands. Every time I have used Zbuffering to make a better looking hole, the anti aliasing on all the items in teh sceen goes very bad. Surely someone else must have noticed this by now?
Or is it perhaps due to my graphics card?


(IamInnocent) #15

Representation OpenGL in Blender is the business of the Graphic Card but rendering has nothing to do with it, unfortunately.

I’ll check into that.