Texturing headlights (actually stop lights on the back)

I have been trying to use Sonix’s car library (I think that’s the name) for texturing my headlights, and I fail miserably:

What can I do to make it look better? All I need is a starting point, then I should be ok.

Use ray mirror for the inner surface of the lights. Be sure that normals are pointed in the direction that the lights can be seen from. Place lights with high values pointed toward the mirrors and use light groups via the GR: field and “Exclusive” button on the shaders tab to keep those over exposed lights from blowing out the rest of your scene. Alternately you can use the Light: field on the render layers tab for the same type of effect. This is a much more versatile option but you HAVE to know what you’re doing in order to walk this path. Using ray trans for the lenses in front the mirrors results in an awesome silvery/shimmering effect (but not from all angles - this is really great for headlights). Placing a single vertex in front of your tail lights with Halo option and Lines enabled gives a very nice brake light effect.

Thanks for your response. Do you mean I should add a new part underneath and make it a ray mirror, then add the lights and make them exclusive to the material underneath?

If you have the time, a very simple circle mesh example would be great.

I’m using yafray if you couldn’t tell by the pic, by the way :slight_smile:


or just set the lens material to red and emit to .033.

Well, If your lights don’t have a reflective interior surface (as real lights do) then they’re never going to look like real lights. As far as Yafray goes, I don’t know a thing about it. I don’t know which of Blender’s features are exportable to Yafray. The un-reality of 3D is what drew me to it and what keeps me in it.
If you enter a light group for a material and press the Exclusive button then any other objects that you want to have lit by that lamp must have the lamps name entered in that same field. This allow lights to shine through objects which do not have the lights name enabled as if they were not there.
The image looks much better than what I can post on this site due to size limitations. Oh, you can’t get effects like this with emissive materials, they’re just cheap and ugly.

…and a .blend to look at:



My group thing isn’t working… I’ll figure that out though, let me ask you one more question.

Should I add raymirrors behind the object in squares to get this effect?



New problem, exclusive lights don’t seem to be rendered in yafray:

No. Use a cup shaped object. Just place a light inside the tail lights and don’t worry about the exclusive option if it’s not supported.

group thing: http://wiki.blender.org/index.php/Manual/Lamp_Types#Lighting_Groups

I started blender through a terminal, and it seems to ignore those groups (it says found duplicate object, ignoring…), but it works fine with blender internal. Anyways, here’s what I have now… not THAT much better – the car texture is better though… I also modelled small rings on the white part, and may do the same for the yellow part (red looks fine though…)