Texturing in blender 2.55, Material doesnt display on UV'd Object

I am just trying to get the basics down in blender. Ive been using Maya and Max for the last 10+ years.

It is beyond me at this point, but I cannot get a material to properly display on an object in blender. All objects just display as white.

This is the 5th various object I have tried and at this point I am stumped.
This example of in the screenshot, is a simple plane that has been uv’ed,
the material has been assigned, a texture assigned to the material.

The texture displays in the preview window, but not in the 3d window of blender. Its fairly frustrating as this is possibly one of the simpliest functions of all 3d software.

Any guidance on what magical step must be performed would be great, thanks!

The texture is there alright, you just haven´t told your Blender yet do display it in the viewport =)

You have to turn shading from Multitexture to GLSL mode and add either one or more pointlamps to the scene (else all will be black) or check “[x] textured solids” in the viewport options as seen in the center of your screen.


Thank you, that fixed it instantly.

Is there a default lighting option as when I export the fbx I cannot have cameras or lights.

Thanks again for the quick and pleasant response!


You´r asking if there is a default lighting setup in Blender? I am afraid not.
Personally I got a camer and light setup and if you press [crtl]+[u] it will be saved as default and next time you open blender it is there.
If you import another file, the setup will remain as it is.
If I don´t need the setup I just press [a] (once or twice depends if there´s something selected) and [x] and all is gone.

Alternatively you can create a light and camera setup and save it to a blend and once you imported your stuff, just append the blend file, or load the scene and link it to the current. Possibilites are really endless, just play with it. Blender likes to be played with, then it is nice to you as well =)