Texturing in the BGE

I can’t seem to make textures work in the Blender Game Engine. I add textures that appear in my renders but when I try to run the BGE they don’t show up. I think there is something immensly simple I’m missing but I can’t figure it out. Is there a button I should press that enables textures?

post your .blend file

  • proof that texturing is possible :stuck_out_tongue: http://2mean.com/s/tex_are_possible.JPG

Hello
built-in textures ( procedural) don’t work in the game engine ( unless you bake them).
You must use the UV Editor.
Bye

Just a theory, you know to go into textured mode right?

Incredibly simple but it’s quite possible you don’t have it set. click the button beside where it says object mode to select modes or press Alt + Z to switch to it.

Thanks Rorkimaru but yes I have tried that, I think the problem is that as OTO said I only used blender Procedurals… I’ll try again with UV map or baking. Thanks!

By “built-in” textures I assume you mean materials?

Materials will work. You just have to be in GLSL mode (or I assume multitexture materials will work too though I haven’t messed around much with that mode). However if your graphics card isn’t up to snuff you’ll probably be stuck with the regular graphics mode and, therefore, UV textures.

Ya I have an older graphics card but I tried UV Textures and baked the procedurals to it and it worked out beautifully! Thanks so much everyone! I had heard about baking but I didn’t really understand how it worked. Whenever I tried the bake button it would say no image. Finally I realized I had to creat a UV map then and Image and it would work… Thanks a lot!