Texturing model with an image that doesn't match

Hi! first of all, I’m not sure what kind of title to write so I hope the one I chose was good.
I’ve been trying to make my model into a player model for GMOD. Following instructions, I exported my model into .smd format. I noticed that when re-importing it, the polygons were different (right image is .smd version):

And as I guessed so was the UV map (second one is .smd version):

So before doing anything else on the GMOD tutorial, I got stuck trying to figure out how to texture the .smd version with the textures I had made for the original model (note: the original textures were baked on an image from assigned materias, so it won’t be that hard if i need to re-bake it a different way. I just don’t know how).

Thank you!


When you export by SMD, if the script cannot find a UV map on the object to be exported, it will automatically unwrap the model based on some arbitrary angle. The script will also triangulate the mesh, because the source engine needs to be fed in triangles. Triangulation itself likely doesn’t affect UV maps.

If you have the original blend file or model which you made textures for, I would make sure the UVs are OK and try to re-export it.

If not, I would just use the occasion to make a proper UV map.

Or, if you have both the original model and the exported model at hand, and just need to transfer UV maps between, try the following:

1 Make of duplicate of your original model, for backup.
2. On the duplicate, go into Edit Mode and Ctrl+T to triangulate the mesh
3. Go back into Object Mode and deselect everything.
4. Select the exported model (the SMD one) FIRST, hold Shift and select the duplicate SECOND.
5. Hit Ctrl + L, and choose Transfer UV Maps.

The exported model should now have the old UV map.

You should always use meshes within blender and in .blend files, because a lot of properties get discarded when exported to other formats. If you need to update a mesh, always have a working blend file where you do the updates from, then re-export it.

I tried the second option but it didn’t work. It wouldn’t import the SMD correctly anyway, so I tried again after a while. The second time the SMD loaded correctly but there was no need to transfer the UVs, the textures just matched when I imported the model, so I re-baked the materials. I’m not sure what happened either, but it seems to work now.
Thanks a lot!