Thanks

hi,

im sorry i have to start a new thread for this, but i can’t find a hint how to solve my problem in the other threads. :o

i have an image of a simple black number on white backround. i would like to map only a black number onto a green object (please view attachment).

so now, how do i turn off the white of the backround of the mapping-image and make it transperant so i only obtain the black number or symbol onto my object?

i use UV-mapping and select only one or two faces of the object to map the image on to, but then the material of the whole object adopts the color white of image backround, which is the whole problem. i don’t want the white or any texture other than the black number in the image.

is that somehow possible in blender???

thanks to everyone for response.

Attachments



The white part of your source image needs to be transparent, and the file needs to be in a format that allows alpha transparency (e.g. PNG or TGA). In a nutshell you need to use your image editing software to erase the white parts and then save to one of the above formats.

When you use the image as a texture by loading the image in, in the buttons window there is a button in the “Map Image” part of the texture buttons that is labeled “Use Alpha”. If it’s working, you should be able to see it right away in the texture preview.

well alright, thanks then, i’ll try to erase the white with an image editing program.

by the way, which tool would you recommend? is gimp practical? i haven’t got it yet.

how would i limit the image mapping to only the selected faces, in case i wouldn’t mind the white backround that much as long as it doesn’t cover the entire object?

and another: what are sticky texture coordinates (viewable in the mesh buttons panel)?

Maybe you could try ‘calc alpha’ instead of ‘use alpha’ under the texture tab, the one where you loaded the image.

i just tried that but it doesn’t seem to have any effect. :no:

but thanks anyway. could’ve worked. :wink:

hi,

i’m a bit frustrated and need professional help :o, pleeeeeazzzzze.

since hours and days i am trying to avoid that all unselected faces of the base object (see pictures of the bob-sled) take over the backround color of the image i am trying to map to only two selected faces

i somehow need to make the white of my source-image transparent. i tried all sorts of alpha settings in the material and texture panels, but nothing works.

in photoshop i properly erased all white around the black number and saved it once as .png and once as .tga picture file.

then i loaded them both in blender into the UV Image Editor but nothing changes.

as you might be able to see in the pictures the original material color is and should remain light blue and only two faces on the front nose are supposed to be mapped, but only with the black number of the source image.

what am i doing wrong or which buttons did i miss to set correctly ?

are there any ideas?
.
.

Attachments




Sorry I missed this earlier. No need to pull your hair out. I’ll run through it all so as not to miss anything…

  1. Material buttons (F5): Material panel: your material RGB should be green and the A slider should be all the way at 1.000.
  2. Texture panel: you should have a texture defined here, with a check mark in the button next to the texture name.
  3. Map Input panel: make sure to have clicked “UV”.
  4. Map To panel: you shouldn’t have had to change anything here. Make sure “Col” (color) is clicked, and the texture blending mode is “Mix”, and the Col slider is set to 1.000.
  5. Texture buttons (F6): Texture panel: your texture type should be “Image”. With the image properly loaded the Preview panel should show you a big black five on a white background. In the Preview panel click the “Alpha” button (not necessary, but it’ll help show what’s going on next).
  6. In the Map Image panel, click “Calc Alpha”. The black of the five should turn transparent. Of course, you would rather the white turn transparent, so click “Neg Alpha”. Alas, nothing will happen in the preview, but you’ve done the right thing.

If you press F5 again for the Material buttons the preview panel should now show you some green stuff with a black ‘5’ on it. Personally, I would also click the “Full OSA” button in the Links and Pipeline panel.

Hope this helps.

hey well thanks to you i got rid of the white opacity, :yes:.

but i still have this awkword effect as you see in the last picture, the number is duplicated on all faces, what i bet is also the cause for the former white painting over the entire sled, although i had only one number on front. strange :spin:.

now i only need to restrict the texture to the only two faces selected in the UV Face Select window. it’s probably terrifying simple but i’m having one hard time of figuring it out and all i can do is trying around.
but i’m not giving up. the anoying thing is i have like only a quarter hour of spare time each day for practising in blender.

do you happen to also know an explanation to this final defect?

Attachments


Activate UV/Face Select mode and make sure that only the faces you want to have the ‘5’ on it are selected. Tab into edit mode. Those same faces should still be selected. Press F9 for the edit buttons. On the right side of the Link and Materials panel click “New” to generate a new (duplicate) material, then “Assign” to assign that material to those faces.

Now click F5 for the Shading buttons. In the Links and Pipeline panel you’ll see a number “5” in a little button next to your material name (“MA:Paint”). Don’t click it yet.

First, go all the way over to the right and unclick the little check mark next to your texture name in the Texture panel (“Tex”). Now go back and click the little button with the “5” on it. Respond OK to the popup “Make Single User?”. Now go back and re-click the button to get that check mark back.

Clear as mud, right?

What your problem is is that all the blue faces on your racer share the same material --a material with a big black ‘5’ plastered on it. The fix is to create a new material index, assign only those faces that should have a ‘5’ on it to that material, and remove the ‘5’ texture from all the other faces.

Hope this helps.

Sorry for the double post. I looked at your screenshots. The little button you need to click will have the number 6 on it, not 5, since I had you add a new material index.

Just in case you are looking for a little button with a 5 on it… :eyebrowlift:

hi thanks!
that made it work.

you are my hero, Douas! i finally got it, thanks to you :):):). i bet i would have stuck on this for years. i really fell in love with this forum. you volks are the greatest!!!

before this it somehow had a similarity with the Joker from Batman.

now so far so good :). and i guess i can now move on to the radiosity chapter :confused:

although, by this chance i stripped over something else making me wonder.

i couldn’t figure out yet what the image select list / file browser in the UV Image Editor window is good for, when the same image has to be loaded into the image panel of the material buttons window first as well as anyway.

and secondly i noticed another rather unpleasent effect: the mapped image, in this case the nr. 5, is visible on both sides of the faces, inside and outside of the sled (as you can see in the pics). now it seems logic when you look at the UV Face Select Mode (second new picture) and notice that the whole surface is completely invisible in one direction.

but why is that? and how do you switch it off?

and for the last: what could i accidently have changed in the settings, that when i press F12, the render won’t work anymore, it seems as if blender were trying to render an animation. only a black screen appears in the former buttons window :confused:.
.
.

Attachments





I think there is a setting in the UV Calculation tab, the texture face tab, for Double Sided- maybe you have this checked? Or maybe in the mesh Tab, there is a Double Sided button that is on by default in mine.

Hey, thanks. Hang around here and you’ll learn. :smiley:

I can’t tell from your images what system you are using. If you are running blender in the fullscreen mode (the default), sometimes the pop-up render window moves behind the blender window, and the main blender window is totally unresponsive while rendering.

If you are on Windows and you can see window decorations (titlebar and borders), just press Alt-Tab to switch to the render window or minimize the blender GUI window. I’ve not actually ever tried to run blender in linux or on windows without window decorations…

You can also switch the render output to direct itself to the UV/Image Editor.

You don’t actually load the image twice. In the texture buttons you have to link it to your texture. Go to the outliner window and take a look at the OOPS Schematic to get an idea of how Blender stores information.

Hope this helps.

If you only want the number to show up on one side of the mesh then Broke built a material node specifically for this (I believe he was mapping pages of a book). You can find it in SVN here:

This is for a Windoze machine. I’m sure the node probably exists in builds for other OSes but I don’t know in which ones. It looks like the following image:

.

Attachments


:spin::eek::spin::eek::confused::spin::confused:

hello,

and sorry for not having responded immidiately, i missed checking in on my posted question.
its just that i don’t have enough time to do so regularly. but now i want to express my appreciation for your answers.

thank you very much for your help :slight_smile:

i unfortunately don’t understand the suggested solutions though:

  1. i turned the “Double Sided”-button on and off, but none setting effected the inside mapping of the selected faces.

  2. i am not fimiliar with the Outliner window and nodes yet so i won’t be able to try that out so fast :no:

but when i find out the answer, i 'll posted it right here :yes:.