The 2 noobest questions ever!

  1. how can i enable collisions in game so my character doesn’t go through a wall or barricade.
    2.when i am moving an animation resets the character to point of origin, where the animation took place. HOW DO I STOP THIS!!!:mad:

Thanks for the help in advanced:)

Go to the physics tab, and make sure that the objects are either static (for things like walls and floors) or dynamic (for characters, or anything you want to move).
Also make sure ‘ghost’ isn’t checked, and use servo motion rather than loc.

  1. To stop the reset position, use a collision box, and have the animations on a character parented to this. Or you can remove the location channels from the animations.

To build on that, if the physics tab just has some buttons for cloth physics and softbody and force fields and fluid and whatnot, you have to switch the engine to game engine (there’s a pulldown at the top of the window that says “Blender Render”, just pick Game Engine from the list)

And for characters, animations should be applied to the armature, but the armature and character mesh should be set to no collision, and the armature should be the child of a box that handles all the physics and motion; any motion should be done either with logic bricks (via the motion actuator) or in python (you’ll want to get familiar with the rest of the game engine before you delve into python, but there’s only so much you can do with logic bricks alone so I wouldn’t put it off for too long if you want to make games of any real complexity)

Sorry dear sir, but I got complex some time ago. I just didn’t understand how collision really works. But thanks for the advice.

Sorry, but nothing works. many other ideas?

It should work the way sdfgeoff suggested, if it does not please post a simplified .blend and we can help you easier.

Oh well, sorry guys for not making myself clearer. My mistake. The reset position has stopped, thanks for the help. It is the character that still goes through the barricade and walls. It recognizes the floor though. I thought i would duplicate it to see if it works but for some reason it doesn’t.

So you have physics on, and you character doesn’t fall through the floor, but doesn’t respond to collisions with the walls? Are you sure the walls have collision enabled and aren’t set to ghost? How about the collision mask and collision group for the walls and the player? (two objects will only collide if their collision layer is enabled on the other object’s collision mask and vice versa)

On dynamic and character physics type, the character does swoosh through the floor. No other physics type do anything. It may be a recurring glitch or bug, but I really doubt it; Because when i made a new blender file, everything worked fine. So weird, I’ll keep trying and give you guys info, but more ideas would be very much appreciated. If not i may abandon it, but oh well.

If you can provide a simplified example (strip out everything else to isolate the problem) it may be easier for us to help you (or it may even just be easier for you to troubleshoot the problem on your own with a file like that)

Also you might not have bullet enabled! Check in the world tab if you have phsics enabld.
As for the cahracter, the parent box sould be the one doing the colisions. The floor and walls should be static, the box dynamic or rigid body, (character seems to be + appropriate though).

how can i enable collisions in game so my character doesn’t go through a wall or barricade.
As said above, a bounding box is the way to go, how? make 2 cubes, go to physics tab, cube 1 will be characer, put type on no collision. done here now select cube 2, this will be the bounding box. in physics tab select type dynamic, then scroll down and select collision bounds keep it on box. now thats done. now u want the box around the character, select your character, hold down shift and select the box, now press ctrl+p, and parent it. now u can drag the boundingbox and the character goes with it. so select character and place it within the bounding box. and your done, add a motion, force or whatever movent u like to it… Now the floor/walls part, make a cube or a plane, go to physics tab and scroll down, enable collision bounds. and you are set. move your char into the wall and it wont go through, this also counts for the floor. If u do it right u can then animate your character and thats basically everything u need to do with the character, any other action u place it on the boundingbox (like the movement, etc…). hope this helps, here is a .blend file with what i have explained here (tried too).

Okay guys, progress! It appeared the objects set to the parent cube made it do some weird stuff. So i set them to ghost. The parent cube is on dynamic (now character as it has a better collision), and it collides with walls now. Yay. It did go halfway through them but i solidified the wall and that works now too.