The correct way of putting cloths on humanoid models?

First, the render with cloths, then the render without cloths.
What you should be able to see, is too stop the body from poking through the cloths, I shrunk the body under the cloths in edit mode. Is this correct way of solving this problem? Should I have deleted them. I’ve been reading on the subject, and they said to use a deform modifier during animation? They said to break up the body in pieces so they could be toggled off. Or just delete the vertices.
The model was rejected by sketchfab, and I learned from critique some problems with the topology, but would they have rejected it because of this method for stopping the body from poking through?

With the clothing article.

The shrunkin body.

Try the physics properties, under cloth, look for collision and enable self collision and object collision