The edges on my shadows are jagged when I render.

Can you tell me why my edges appear jagged when I render? I appreciate any feedback you may have! I’m not sure where to upload the blender file, but I’d be happy to share it if someone wanted to take a look.


You are using a spotlight with buffered shadows, and the buffersize and samplingsize is too low.
Either crank it up, or turn on raytraced shadows.

arexma, thank you for your response! My buffersize is set at 4096 and my samplingsize is set at 16. I’ve included another render with my buffersize increased to 10240 and one with raytracing. It still looks a bit jagged. I was also wondering why there is shadow missing under the molding around the bottom of the window frame in two places. Any feedback will be appreciated!


Make sure your buffer shadow clip start and clip end values are set to just the distance you want your buffer shadows otherwise you are wasting a huge amount of the buffersize. You could try ticking the autoclip boxes or set values.
Read up on buffered shadows here

Raytraced shadows should not have the jaggies.
Also somethins odd, I see light being emit through the corner of the room and under the wall below the window.
It´s also possible that your Spotlights angle is too wide. Causes jaggies too.

What lights with what settings are you using?
Are you using approx. AO? Then your samples are too low. For static scenes I´d use raytraced AO with 10-16 samples.

I really don´t use Spotlights unless I absolutely have to for speed reasons, or when working with BGE.

Using Spotlights is fine (it was all we used for Big Buck Bunny), but it doesn’t handle sharp shadows well. A sunlight would be better in that case.

Also, is it for animation or just a still? that would matter. If it’s animation, I’d say go for spotlights as much as you can, and AAO. If it’s a still, it should be okay to use raytraced shadows and AO

Thank you very much for all of your suggestions! I’m still having trouble, so I’m attaching my blender file so you can see what I’m doing. Maybe some of you can look at my file and tell me what I’m doing wrong. I’m working out of a book called Blender Foundations and I’m following the tutorial which will eventually animate.


Room_Scene_2.blend (624 KB)

Got rid of almost all lights in this one. Didn’t make much a difference anyway. There were some problems with the mesh at the window frame (was an open mesh), so replaced it.

Just 1 sunlight, can still increase the samples if needed.

Used AAO, with a low value for Error (higher quality). If during animation there is flickering in corners and edges, disable ‘Pixel Cache’.

I also set ‘Dither’ to 1 (in the Render properties under Post Processing), to get rid of the banding. Perhaps with additional lights and textures this can be set back to 0


Room_Scene_new.blend (613 KB)

Sago, thank you very much for helping me understand what the problem was! I was unaware of the problems with the window frame, thanks for pointing that out! It was enlightening to see that one sunlight was all that was necessary, I’ll keep that in mind. So, having too many lights was contributing to jagged shadows? How did you know that the window frame had an open mesh and how do I avoid making that same mistake again?

I think Sago fixed it all.

A hint for checking non-maifold meshes / meshes with holes:
If you are unsure you have some, go to textured view, or set object to “smooth”. If you now in editmode press <ctrl+n> to recalculate the nromals twice or more often, and the normals keep changing (you´ll see the faces change shade clearly in those modes), you got non-manifold faces or holes because Blender can´t determine what side is the outside of the mesh.

Or you just try to select the non-manifold and delete them :slight_smile:

Thank you, Sago & arexma! I went back to the original file and was able to see the open mesh. Thanks so much for helping me!