The First Connected to the Second node...

This may be a simple question to ask, but hard for me to pull off. I have a total of 3 render layers on the same scene. I use an Alpha over on the first two. If I want to add the 3rd layer to the node tree, do I use another Alpha over node or do I use a different node. If a different node is needed, what’s the right node to use?

Did you try the AlphaOver node? Does it give what you want or not?

The “need” for a node depends on the elements you want to combine and the result you are after. AlphaOver is for combining two elements where the one on top (in front relative to camera) has alpha channel and you want to use its alpha for coverage. If your element does not need alpha (render passes, additive light elements etc), use other nodes, Mix for example.

Well, I don’t have an alpha channel on most of the objects in the scene except for the windows but they have transparent materials. The camera angle that I have doesn’t show it. But, I will try using the Mix node.

You should read up a bit about what an alpha channel is and what it is used for in compositing. Having an alpha channel in a rendered element (layer) has nothing to do with whether any object has transparency in its shader or not.

Okay but all I’m getting is just the showing of 1 layer. I also have a RGB Curve, a Glare and a Color Balance Node in the setup. Could that affect it?


Not sure exactly what you’re trying to do here, but if you want the world or “sky” to be transparent in Blender Internal renderer do this:

Go to Render panels -> Shading -> Change Alpha from Sky to Transparent
If necessary, in Render -> Output -> make sure RGBA is checked
May also have to go to Scene panels -> Layer -> Turn off Include: Sky

If this doesn’t work, please include a link to your .blend file, or at least the entire node tree/interface so we can see what you’re doing.

The file size alone is a bit over 40 MB. I don’t know where I can upload it. I had it under a different output in order to bring it back the RGBA option. Now, the scene is an indoor shot. I was able to get 2 of the 3 layers. Here’s what the other part of the set up looks like.


Try this for the first approximation. Since you have Background and 2 images with alpha you have to make use of this information which determines where pixels need to be colored using color info from image. Guess second node can be ColorMix also. http://www.pasteall.org/pic/show.php?id=105110


It showed up but not the way I would like it. The only way I can upload the file is through Mediafire. So I’m going to post the link to it.

http://www.mediafire.com/download/iaa86eab1buipf9/Main_Character's_Home_2.blend

Actually, all what’s needed is your 3 rendered images and node group you use, all packed in one blend. The question is Compositing, not rendering or setting render layers…
On the other hand this is a question of layers and object visibility…
You have room and this has foreground and background. Make sure table, pc and character are on one render layer and there wont be such problems. Right now you could use Object ID masking ( if you had it set before render) and could painstakingly combine masks and parts of layers in proper order. This is not optimal tho, imho.

Well, now, it’s crashing. It was an animated sequence and for some reason, it keeps crashing after the last camera marker. I thought it would solve the problem but it didn’t… Back to the drawing board.

Well, after many hours of trail and error, I was able to fix the problem. What I did was have the character’s layer share in the same layer as the other 2. Then I used 2 mix nodes and now all 3 exist in the same space. Thanks to those who advised me. Now I have to continue with the hardest part; finding more references for the animation.