The geometry nodes’ viewer has something missing

It displays the attribute, but not the geometry. That’s such a hassle.

The viewer is not meant to visualze the geometry but the attributes. In order to preview the geometry press alt + shift + click (with node Wrangler enabled). It takes some time to develop the muscles memory to press alt instead of ctrl.

Ultimately it’s supposed to handle previewing geometry :

1 Like