The Lightmapper v0.3

@Naxela, I think I had a hard time trying to explain the flow. But I found a product for 3DS Max that kinda does what I do manually, but in 1 step: https://www.texturebaking.com/

@Nexla
I had some problems while baking lightmap for metal material(metallic = 1)
since the metallic value = 1, it is supposed to bake glossy pass instead of diffuse pass.
but when i am baking lightmap for it. all metal material turns pure black.
here is render in Blender


here is after baking lightmap

here is the bake setting
image

Hi, thanks for trying out the addon

The addon is only supposed to bake the light, and light hitting metallic objects will usable return black, thus usually you wouldn’t want to lightmap fully reflective objects either (like a mirror). The glossy pass won’t fit the purpose, as if you’ve combined objects where one part of metallic and another part is dielectric, then the lightmap will be wrong.

What would be the best outcome instead is if the metallic values are ignored at bake-time or clamped, which are new options the upcoming 0.4 version:

billede

For baking glossy passes, I recommend instead using BakeTool or EZ Baker mentioned above.

1 Like

Thanks for the reply.
Will there be any discord server so that we can have a small community and we could help each other.
That will be nice since now we dont have docs about it.

Hi, I could probably add a discord server at some point while I’m writing documentation. In the meantime, feel free to send me a message to my Discord user or add me - I think my username is Naxela#7255

I had sent the friend request. please confirm! thanks

1 Like

Hi, first of all, thanks for the extension, it’s amazing and so helpful !!
I have a problem, however. “disable selection” does not work. I have tried everything, even when using a new blender file with a new name.
When I bake an item, it continues to bake the previous items. Is there a file where the information is stored (cache ?) to be removed manually if necessary?
Thank you in advance ! (blender 2.9 + the lightmapper 0.3.1.1)

Hi and thanks for trying out the addon,

It sounds strange, as if the “Enable Lightmapping” option is left untoggled (same as what “Disable selection” does) it shouldn’t bake the other items:

image

There isn’t any other files, as most of it is stored in object properties, but what you can do is to try out the upcoming v. 0.4 branch (wip release available here: https://github.com/Naxela/The_Lightmapper/releases) and see if it works for you

There might be some stuff that was fixed for the 2.9 version (v.0.3 was mainly for 2.83)

Thank you for the quick reply.
As you can see, I unchecked the box for the 3 objects but that doesn’t change anything.
It is possible that the bug appeared since I installed blender 2.9.
I have an error with version 4 when I activate it : “no module named The_Lightmapper-0” in…addons_utils.py line 351

That sound strange - I will investigate, and probably also upload some new WIP releases either later or tomorrow.

Thanks for letting me know!

Stupid question but how do you install the OpenCV?

Hi,

It should be possible to install OpenCV through the preferences menu (Edit > Preferences > The Lightmapper; If you’re using a recent version of TLM has opened blender with admin rights):

Otherwise, you can install it as a python module manually from Blender’s bundled python installation (using PIP) if that fails, although that’s a bit more complex

Thanks for the reply I’m really enjoying this add-on. Another stupid question I have is, is there a way just to bake indirect lighting?

Hi,

That’s ok, there’s no stupid questions until I’ve gotten myself together to write documentation. In order to build only indirect lighting, it should be an option located under Lighting Mode (at least in WIP v. 0.4, not sure it was in 0.3) - Although by default it’s quite weak, and depending on your scene it might provide better results if you increase the exposure multiplier:

Hope it helps

1 Like