The navmesh and its' discontents

I am having trouble implementing a simple navmesh. I’ve tried the method of creating a navmesh from the main plane and also tried creating a navmesh out of another plane and placing it over the main plane. This still doesn’t work. What is puzzling is that sometimes I can get the navmesh to work; other times it stops. I’ve uploaded a recent example and I would greatly appreciate pointing out what I am missing on this exercise whether it be a property setting or otherwise. Thank you in advance.


navmesh-example.blend (777 KB)

I’ve concluded that you forgot to apply the object’s scale. That’s all I had to do, just Ctrl + A, then “apply scale”.

That should solve your problem. Also, don’t forget to invert the normals after. Simply press Ctrl + N. That should do the trick.

Hopefully, that worked out. Since this was my first time solving a problem on BA.

Thank you for the reply. Unfortunately, that didn’t work. I tried applying scale on the object using the navmesh - no go. So I tried applying scale on all of the other objects - still a no go. Btw, Ctrl N tries to reload the startup file. I tried Shft N but that didn’t appear to do anything either. Any other ideas?

I try create navmesh and not working property the blender game is gone out.I,m sad but this is the truth none solve that problem

Aye, sorry if I forgot about this. Do you know how to invert the normals?

You could just search by pressing space bar, then searching “invert normals”. That should probably do the trick.