The New Particles .. let's figure them out

Works all right for me here.

  1. Did you unwrap your mesh properly? Can you see your object with the UV-Texture in Draw Type textured?
  2. Now assign a UV-Texture and render your object. Do you see the UV-Texture in the render?
    Make sure you have only one material on the object.
  3. Make a particlesystem.

Should work right out of the box.

jiii: great tip. thanks. That’s the kind of thing I’m supposed to think of.

You’re absolutely right!!:eek:

Made a cube. Unwrapped it. Textured it. Viola.

Problem though-

Just doesn’t seem to be working with my spider model, no matter what settings I seems to use.:no:

Perhaps because it’s from the standard 2.45 build?:spin:

Edit: Wait… there is a bit of variation in the texture. Just not at all accurate. Just 4 of the legs show color change :(. Moses seems to hates me.


Once again it was the order of the modifier stack. I have subsurface on the model. The particle system has to be above the subsurface.

So the order goes:

  1. Armature
    2.Particle system

Yeah, the modifier stack needs serious attention, especially subsurfacing and particles. The real problems begin if you use a softbody animation for the hair on a subsurfaced object.

But I’m very content the übercool blender coders will solve all these issues. :cool:

I have had some strange things happen with hair particles and baking/cache issues. I’m also still pretty unclear about the “protect” and “clear” cache options. I kind of imagined that “protect” was something like baking, but, yeah. If anybody has any insights into how those things are similar to or different from the old baking system I’m all ears.

Does anyone know if it is possible ( with the new particle features in the SVN) to turn the hair strands into actual mesh object? This would make it possible to export them to different programs.

That’s a good question. Also is there a way to group the hairs while editing them, or make is so that you only comb one side without using multiple systems?

Documentation in the release logs for particles is starting to get more fleshed out

Theoretically you could select particles and hide them, just like vertices. But the only selection tool in particle mode that works as of now is “select all” (a-key).

You can mirror the hairs and use X-Axis mirror editing (in the particle menue). But beware, the result is not totally symmetrical for the children, there are loads of issues.

Does anyone know how to use keyed particle systems? I can get them to render as strands, but not particles moving from one object to another. I guess that the first object should have a particle system set to “emitter” and “keyed” and have the “first” box selected. I really have no idea whether the target particle system should be an emitter or reactor, or if it should have keyed dynamics too, or what, but I’ve tried every possibility and can’t get anything to happen…

Keyed particles aren’t working right now (they were in previous builds, but now they’re being fixed). But I think you’ve got it basically right. I think the target particle system can have either newtonian, boids, or keyed physics. When the keyed physics was working it worked with emitters at least, and I’m not sure about reactors. Probably they could work with either though.

I made this tutorial, but it’s only for hair.

It’s for the basics, but it should get you started with making hair ^_^.

thanks falgor for taking the time to put that together for us

No, problem. I hope it comes useful =). Now I just corrected some typos there.

Wow, I’ve been fooling with this thing since december and I didn’t even know it was that flexible. :open_mouth:

Hello fellow threaders,

I am running to a bit of hair particles rendering weirdness. Take a look at this chicken:

Beautiful pack of feathers, except for the head where all the feathers are clearly overexposed. The part with the problem is that consisting of feathers I cut with the cut option for hair so as to get shorter feathers for the head. Why do they render out this white ?

Would you mind posting a sample blend of how you did the feathers. Every attempt I make fails to even render :frowning:

Ropsta, there you go:


Thank youz much.:yes:

I’ve managed to figure out the problem. It was the build I’m using. When I step it back one build it renders just fine. Excellent work man!!

does anyone know how to set a goal for boids?