The new Yafray interface


Im trying to obtain the same result as mrNeil on his picture. He has used Yafray exporter.

But with the new Yafray built-in interface I cant make the samresult as on the mrNeil image.

Here is the original Yafray image(made with yafray exporter):

Here is my render through the new yafray interface:

And here are the settings that used for:

Can somebody point me, how can I obtain the same result?
(If it exists some documentation about, I will read it)

Best regards,


The last few days I have tried all the possible settings I think, but I cant reproduce refraction and reflection.

My object isnt transparent! But at the material settings I have set the Alpha value to 0.1.

What should I post to help if somebody want to help me?

Best regards,

it is in your materials! have these settings!

raymir - .08
fres - 0
ray - 4

raytransp - 1.5 or so depending on type of matter
fres - 0 or just allitle more than that
ray - 4

here is the key:

ALPHA - 0 or just a little more than 0!

took me forever to get that too!

you might want to try caustics out too! :wink:


Thx for your reponse. I have tried, but didn’t helped in refraction and reflection.

Here is the result image:

And here is the material settings for the logo:

Its sure, that something trivial is wrong. If it help I cant email to you the .blend file.

Best regards,

turn your depth and cdepth up to like 20! your welcome! keep em coming! :wink:

Did you even set refraction and reflection in the material settings? Also, to me it seems that the original image is lit with some hdri, but surely has something to reflect. Does yours?

Yeah, it has a plane juste behind the spot lamp.
So in the scene I have 2lamp(1 hemi and 1 spot) and a plan(emit=1.0 and specTra=1.0) just behind this lamps.

I have rendered an another image with CDEPTH 30 and DEPTH 30.
But didnt not change to much:-(
Here is the picture:

Any idea?:wink:

(I can email .blend file if requested)
Best regards,

Looking at the material settings for the logo, you should change the IOR slider (to approximately 1.5 for glass, other values can be found here:

Hope this helps,


I’m pretty sure you don1t have reflection and refraction set for the material. I’ve done a simple render with only the hemilight lighting the scene:

and one with hdri:

so now I think I was wrong and the one above doesn’t have hdri, but now I’m fairly sure that you don’t have your materials set right, or you have some installation problem, or I don’t know :slight_smile:
So, did you go to material settings, and did you click on “Mirror transp”, and did you click on ray mirror and ray transp, and did you set some mirror reflectivity there with the slider, and did you set some ior value next to transp? If you did, then I’m out of ideas, I get results like you do if I don’t set the material to mirror and to refract.
edit: Looking at it again, I see you do have some reflection on the side there, so you just need to push it a bit higher, and set more ior.

Do you have a Phonton light on the scene (I think one of those is required for caustics)?

ERufailon: I have sended you a privat message;)