The problem with brushes when sculpting on the tablet

Hi guys. I work on a tablet Huion H430P. That’s the problem with Blender 2.8. Brushes work strangely. The “Add” brush adds or subtracts depending on the angle of the camera. “Subtract” works the same way.
Video: https://youtu.be/_F4jtO_RbOw
Is this a bug?

OS: Windows 10 64x

That looks like a bug. I just got a Huion tablet after multiple decades of Wacom use. My tablet works perfectly in Blender 2.8 (version from 23rd April). Have you tried File>Load Factory Settings? That can sometimes help if 2.8 is acting strangely between builds (things change so much that problems arise when Blender pulls in settings from an older 2.8 build).

Of course, I reset the settings. In the new file is the same.

What build is your Blender version? Huion version? Can you attach a .blend file? The only way I can get a brush to add on one part of a mesh and subract on another (without changing any settings) is if some of the normals are flipped.

What build is your Blender version? Huion version? Can you attach a .blend file? The only way I can get a brush to add on one part of a mesh and subract on another (without changing any settings) is if some of the normals are flipped.

I sent a bug report: https://developer.blender.org/T63868

You blend file work for me OK with the same Huion driver and the 2.8 build from yesterday.

We have different time zones. Tablet drivers are recent. Today I updated the assembly and reset the settings. This did not solve the problem.

Do you have Ctrl mapped to any of the buttons on the tablet or pen?

I imagine this is going to be difficult for the devs to triage, unless someone else with similar hardware can reproduce the issue.

not. I draw purely with a pen. such a problem is only in blender

Do you still have any older Blender 2.8 builds on your PC? Do they work OK? What date was 5a144c797a3b from?

Is the sculp plane setting unlocked? I haven’t sculpted in a while but locking it and changing the setting to one of the axis gives similar results to what’s shown in your video.

2019-04-24

Do you still have any older Blender 2.8 builds on your PC?

I have a build a3b88c917299 (2019-04-10), it has the same problem

Sculpt plane in options? Worth area plane. Other settings do not correct the problem.

Have you ever seen it work OK in Blender 2.8 builds?

Have you tried the build with new Sculpt mode features from: https://blender.community/c/graphicall/dcbbbc/ ?

It seems the problem was in Windows 10. More precisely Windows Ink Workspace. I turned it off through the registry editor. Also in Blender indicated the use of WinTab

1 Like

Excellent news.