The render simply doesn't start

Hello everyone!

First time posting here after months of using Blender smoothly without bumping into any serious issues… This time I’m facing a problem I simply can’t solve, even though I’m trying my best since yesterday!

I have this scene with pretty heavy objects and textures, some volumetrics, so I knew it would be troublesome but I didn’t expected it to prevent any rendering! I have no problem when I preview the rendered scene in the viewport shading, it takes a bit of time to load but it displays just fine. But when I press the F12 key, I get that blank loading field without the usual description (you know “frame 1… computing normals…”), I just have that and nothing happens. If I try to close the render window, Blender freezes and I have to shut it down the rough way.

Usually if it’s a memory issue the rendering window indicates “out of memory”, but this time I get nothing like that!
I tried to lower the samples, to disable the heaviest objects, to no avail… Even when I disable everything it still won’t render!! It’s driving me crazy.

I’m lost and I don’t know what to test/try to solve this. Any insight/feedback would be greatly appreciated.

Thanks again :slight_smile:

Do you use CPU or GPU for rendering?
Go to Window->Toggle system console (top bar) to see if there are any errors reported.

1 Like

I’ve tried both with CPU and GPU, it didn’t change anything. No errors reported.

Try starting a new blend file and appending the entire scene.

1 Like

I did that too, and it worked indeed! But I really would like to understand why my original scene didn’t work… even when I switched to Eevee it still didn’t render! I never came across such a problem in Blender.

Is your scene set up to do any compositing? I seem to remember someone having similar issues and it was compositor related

I also want to know the answer to this mystery. With any problem, even when a work around is found like appending to a new file, it is good to know the real problem. Then it can be avoided in the future.

Can you post one of the blend files?

Are you guys, by chance, using OptiX for denoising? I’ve just made a quick test to see what happens when I try to render an image that way using non-OptiX compatible device such as CPU. As expected, the render crashed but I remember I once had a problem with such configuration with results similar to yours, maybe that was on another computer with much older GPU.
Please give your system specs, maybe the problem is right there, along with specific render settings.

Sorry for the late reply!

In the mean time I loaded a previous version of the file thanks to the autosaves and reworked from there.
The original file still doesn’t render at all, I’ll link it to the post if you guys want to test it :slight_smile: