The smooth shading is too much smooth - how i can "custom" handle the shading?

I have make a model and i wanted to make it smoother.
When i press the smooth shading my model was too much smooth.
So, how i can handle the shading?
Is there any way to put my custom values for shading?

You can mark edges as sharp or use an edge angle with autosmooth

or add additional edge loops to ‘tighten’ the shading

My problem is solved.

But if someone know a way to control the shading how strong or weak will the soft shading will be let me know it!
btw is there any way to do that by material? (to put a smooth material which it will make my shading smooth).

I have found a problem with the “mark sharp” and other autosmooth modifiers.
Marking the edges as sharp it doesn’t really make them sharp but, it actually duplicate the edge in order to not match with it’s behind edges and by this when you apply the smooth modifier the edges are not shading the same and they are seem “sharp”.
But this cause some problems… it leaves open and duplicated edges.
i had click at “remove doubles” and it made the rest of my model back as it was before the “mark sharp” and the other auto smooth options.

So, how i can make a edge sharp without duplicate it or leave it open?

Read the material Richard gave you man. Look at the moon, not the finger pointing at the moon.

Ok, the best way to make sharp edges it is by bevel.
Thanks for your replies

The problem is solved!

There is not exactly a best way. I like to use subsurf with edge loops to sharpen them, because the result is more realistic, but it all depends.
Glad to know you learned something.