The std Library Problem

Does anybody know how to fix the std Library, it can’t be found by Microsoft Visual c++ 2010 Express.
like in the Building Blender Section of the BlenderWiki explained i tried to install MVC++ 2008, but I found only the Microsoft Visual C++ 2008 Redistributable Package (x86) (http://www.microsoft.com/de-DE/download/details.aspx?id=15336).
How can I fix this Problem without Microsoft Visual c++ 2008? Or where can I download it?

I have already installed:
Microsoft Visual c++ 2010 Express
-Sevice Pack1
Visual C++ 2010 Redistributable Package (x86)
Visual C++ 2010 Redistributable Package (x86)sp1 (http://www.microsoft.com/en-us/download/details.aspx?id=5582)
Visual C++ 2008 Redistributable Package (x86)
Visual C++ 2008 Redistributable Package (x86)sp1

Hello Leon95

I was having the std library problem myself with just the VS 2008 Express without SP1 installation. Then I uninstalled that and installed the VS version that comes with SP1 and the std library problem went away like magic.

I got it through the link at http://wiki.blender.org/index.php/Dev:Doc/Building_Blender/Windows/Environment .
The link was titled “VS2008 SP1”.

I don’t know if that would help you or not since you mention that you already tried installing sp1 for VS 2010, but I just figured I’d through that at ya’

Good day!

VS 2008 is still supported, but next official Blender release will use VS 2013 and 2008 support will be discontinued unless massive problems arise. I suggest to migrate to VS 2013 Express ASAP!