The Subsurf Levels in the Shrinkwrap modifier doesn't do anything. Why?

As the title says I cannot get this setting to make any difference. I tried all kinds of permutations of settings and geometries but nothing changes in the results of the projections. I checked the normals in edit mode and those are untouched as well. But it is doing something as I can clearly see that if I set the sub levels to 6 to a high res mesh blender gets bogged down.
I’ve found thisbut it doesn’t help. The documentation doesn’t help either.

Can you explain what is this setting for?

Blender 2.74.5