The "yafray photon GI confuses me" tutorial

Here is a little experiment that demonstrates the photon shooting of yafray (not to confuse with the photon lamp for caustics!)

Ok, so here is the scene with emit=1 on the red and green walls but emit=0 everywhere else and NO LIGHTS:

All you can see are the walls, so lets turn on GI with “full”, “best” and set the depth to 1:

Explanation: The red and green walls are emitting light into our scene and illuminating the white parts. The depth means that only one bounce of light is used. Using radiance cache speeds up the calculations (and makes it “smoother”) but you don’t have to use it.

Experiment #1: Lets add an area lamp the size of the wall to the red side (in the GI settings, make sure photons are OFF):


It acts like a normal area light - yay.

Experiment #2: Go to the GI settings and turn on “photons”:


Oh no! All of a sudden our area lamp doesn’t work?

Explanation: When photons is enabled, yafray will shoot photons from all of your lamps as a helper for the GI! Notice how the last photo is “brighter” than the second one? That is because the photons were shot and helped the GI calculations to hit the emitting walls as opposed to the non-emitting surfaces.

Hope that helps someone :smiley:

Maybe it’s a problem with the monitor I’m using, but I see the four images the same.

1. Area Light doesn’t work because the combination of Area Light and Photons GI activates “dummy” option.
You must export and edit the xml file.

<light type=“arealight” name=“LAMP1” dummy=“off” power=“1.000000” samples=“1” psamples=“0” >
<a x=“4.607227” y=“0.627810” z=“5.629194” />
<b x=“3.836127” y=“0.427927” z=“6.233718” />
<c x=“3.545262” y=“1.383098” z=“6.178530” />
<d x=“4.316363” y=“1.582982” z=“5.574005” />
<color r=“1.000000” g=“1.000000” b=“1.000000” />
</light>

2.
Area Light won’t work if you use the Rect option of Area Light shape. If you need a rectangle Area Light (YafRay) you should scale lamp object (N, ScaleX, ScaleY or S,X,X, S,Y,Y) with the Square option.

Yes, that was the point I was trying to make: Turn on photons and the area light shoots photons to help render the scene.

You can have both an active Area Light and Photons GI.
One little word “off” will solve this problem.

This is one of those things that probably need to be front-ended some day in the plugin or blender UI. Editing XML is not a good answer.

Ahh, you all bag me for trying to show through images what Blender/yafray does :smiley:

It confused me the first time I used it!

I realise that this post is a year or so old but I just wanted to thank Drlog for the demonstration. I think it clearly shows some of the simple options when using GI.

The best bit is that since this demonstration, Blender has got even better! :smiley: