Thea Blender plugin

[TABLE=“class: leftbar mceItemTable”]

Why Thea for Blender?Thea Render is an exceptional quality external rendering solution that is now integrated on Blender as tight as possible. Features such as interactive rendering, materials editing, instancing support make it possible to work inside Blender creating astonishing results with a smooth workflow between Blender and Thea Render. In addition, we have taken the decision to release the plugin under GPL (open source) that, we believe, fits the spirit of Blender development itself. :cool:


Linky link?


interesting. I would really like to see what are the exacts features supported on the gpu, I couldn’t find a list.

Indeed. I’d also like to know if it supports, Deformation motion blur, volumetrics, smoke/fire, and hair?

Aww Thea… this is why I love you. That, and your rockin material editor.

Thea is very nice and not terribly pricey, but this line did give me a chuckle. All in good fun.

It is a pretty outstanding render engine - I just hate the interface. The material system and render modes are for product and architectural renderings outstanding!

Check out what they are planning for the next release in December! GPU and CPU combined. Thea seemed a little quiet for a while before the 1.2 release, now they’re all guns blazing.

I’m interested to see what that means. It’s likely just doing ray intersection tests on the GPU. As far as I know no one has actually pulled off full GPU power + full CPU power.

Damn everything I need in a panel like Blender Internal. And, not a damn node in sight. GREAT!!!

Anyone have any luck getting the plugin to work? I tried to enable it in 2.68, I’d get an import error. I could get it enabled in 2.67 but any attempt to render or export render would get an error.

This is something I had to test, using LuxRender 1.3RC2.

Device 1 = AMD 7970 GHZ Edition 3GB [AMD OpenCL GPU Device]
Device 2 = Intel COre i5 750 3GHz [Intel OpenCL CPU Device]

Speed in Ms/s (Million samples/s), the scene is a ~8k face Suzanne, glossy red mat and sun lamp, dupliverted on a plane.

------- Trial 1 | Trial 2 | Trial 3
–7970- 4.18Ms/s| 4.22Ms/s| 4.21Ms/s
Corei5- 0.41Ms/s| 0.46Ms/s| 0.46Ms/s
–Both- 4.87Ms/s| 4.85Ms/s| 4.87Ms/s

Average 7970 Speed = 4.20Ms/s
Average Corei5 Speed = 0.44Ms/s
Average both speed = 4.86Ms/s

Difference between both and the GPU is 4.86-0.44 = 4.42, so the speedup is fairly close when combining the CPU and GPU.

Note, there was a decrease in speed when using AMD OpenCL GPU + AMD OpenCL CPU, which was slower than the Inel OpenCL CPU anyhow [both the i5 750]

I used to get a slowdown previously (not sure exactly when) when using either the Intel or AMD OpenCL CPU device with a AMD OpenCL GPU

Just a thought, how long will it take us to reach Cycles to that level?

I’m eager to try this but I’m having a little trouble.

Windows 7
AMD 955
8 gigs of Ram
ATi 5750 (13.10 drivers)

I have installed Thea renderer, and I’ve installed the Blender Plugin, successfully as far as I can tell.

I am trying to render a simple red coloured cube. When I render it seems to be stuck in the preliminary stage, blank screen, “THEA:Rendering” written at the top. CPU usage goes to 100%, goes on for a few minute, then I give up.

I also tried to do the rendered viewport thing with the ‘Draw to 3d view’ and ‘Start IR’ thingy. And My system freezes up and I get a black screen in the viewport with the Thea watermark all over it.

Any help would be appreciated. I have watched the quick start tutorial video, but in that video Thea seems to just work ‘out of the box’ and I cant see what else I might need to do to get this working.

Thanks in advance!

I had a few difficulties myself, it’s more or less working for me now, I think it will become more polished in the next week or two. Are you using the latest version? Check Grzybu’s post at the bottom of the page

Check the console for error messages, if you get a message about file location, make sure the export path is valid, and use only absolute paths, not relative paths.

Sorry for late reply, I will try again later, thanks guys!

“Check the console for error messages, if you get a message about file location, make sure the export path is valid, and use only absolute paths, not relative paths.”

I read this and watch youtubu. but same error appeared.

I solved the problem. it’s another reason for me.
Thank you very much.

@those having issues getting Thea demo running - mine worked after making the changes above. (Edit: make sure the scene is saved, not an untitled.blend)

Edit: don’t miss the getting started video:

and the manual:

IF you are still having problems, please make a post containing:
Blender version including build number, Thea Version, Thea plugin version, and a screen capture of your render settings and console output. I will see if I can help. As a licensed user I can log in to the Thea support forums where there may be more information.

Call me a fangirl but I’ll stick with Cycles. It’s competent enough and it’s free. I’m not going to pretend I don’t have hopes that someday (soon… maybe?), Cycles will compete with Thea and Octane. I just hope I don’t sit here hoping forever.