Thinkbox Deadline

Thinkbox DeadlineAt the office we have a simple Deadline setup to share Maya renders between our workstations. I’m doing a quick project in Blender and trying to use Deadline to render an animation across different machines (whole frames on each machine).

Deadline says it supports Blender, it seems pretty straight forward. However, I can not get textures to stay linked. I’ve tried moving the texture files around, I’ve resulted to have them in the same folder as my .blend (very messy!). However no matter what I’ve tried the textured materials show up magenta in the rendered frames.

Anyone using Deadline with Blender? Any suggestions?

I’m using Cycles on the CPU in Blender 2.7. A mix of PCs and Macs all touching shared storage. This Deadline setup is functional with Maya.

I posted this in the “Other Software” forum and received zero responses.

Do you have relative paths set for the textures? Deadline’s Blender plugin is just calling Blender from the command line, so try just running a render that way. Pick a machine that’s not outputting correctly, and try rendering by hand:


blender -b test_file.blend -s 1 -e 10 -a

I have “Mapped Paths” set in Deadline. Like I mentioned, this setup currently works with Maya.

I used that command to render a frame, it rendered properly. I still can’t seem to get textures to show up in a render using Deadline.

We’re running Deadline 5.2. Is that too old for Cycles or something?

I don’t THINK mapped paths affects anything on the Blender plugin besides path to the .blend and the file output path. I was going to suggest checking the log for where its trying to find the textures, but bizarrely Cycles doesn’t seem to actually post a log warning if a texture can’t be found/read! It always just posts a message about packing the texture into the BVH, even if the texture doesn’t exist.

Again, are you using relative paths in Blender? Absolute paths won’t work right between OS X and Windows for a network path (mount points are different), and I don’t think the Deadline plugin for Blender will try to dig the .blend to resolve this or anything like that.

EDIT: If you have absolute paths in your file, use File > External Data > Make All Paths Relative. Personally, I’d recommend having relative paths on by default.

Thank you for the reply. It got busy around here, I ended up delivering this job without using Deadline.

This morning I went and used the “Make All Paths Relative” command it reported that 0 items had been changed. So all my paths were relative. I did a test and still had disconnected textures in frames from all machines.

I then went back and made all the paths absolute and the project rendered correctly on the Macs, but not the PCs. (as you predicted) So, that’s closer.

Any other ideas?

J’s right in that we don’t fiddle around on the inside of the Blend file. Anything that’s stored in there will be used by Blender verbatim.

I usually run a job through, pull the “arguments” and “executable” lines and mush them together and go to test on whatever machine was throwing the error.

If you have something simple that’ll reproduce the problem, feel free to throw it over to us at [email protected] and either I or Dwight will give it a test.

I revive this very old thread as I have the exact same problem with blender 2.90
I have linked files that deadline path mapping doesn’t replace when rendering
any solutions to this ?

bests