This could go on forever :)

've tried for 4 hours to import an image to a plane that has a transparent alpha background that renders transparent in cycles. The image is a tree. I’ve searched tutorials and node advice.

I’m suppose to be able to click import image as a plane. Set the material settings either defuse and transparent or emission and transparent and neither work. The image just renders with the alpha channel as black. I’ve tried different images, all checked as having an alpha channel in Gimp. What ever node configuration I need, whatever I’m dong wrong please tell me.

Thanks


How are we supposed to know what’s wrong with your current node setup if you don’t show it to us (no, the highly simplified material tab does not count)? Please ALWAYS supply an example .blend file that illustrates the issue with any support questions!

File > External Data > Pack all into Blend. Then save the file again. This will ensure that all textures will be packed into the file and we can see them, too.

Upload the .blend file to pasteall and post the download link here.

Make sure you aren’t using a .jpeg. Let’s see some nodes.


Your nodes should probably look something like this, except change the Glossy node to whatever you need it be… The image nodes are the same image. (I like separate image nodes for making my tree prettier, but you could use the same node for both inputs).

if that does not work, in the case of the image being a non-png, you could use the same setup as breagha, but use the color node in the factor of the mix node, and use some nodes to get all the tree as a solid white color by using some keying nodes.

Thanks all. I posted my question at around 5 am here in England and now I’m up again at 12.35 pm for more punishment :slight_smile:

Breagha I tried your node configuration and here it is


I instinctively feel this should have worked but it didn’t


The plane has a UV map and the material pain seems to check out.

Since I added on zero brush I can’t import a hight map because the imported image on the plain won’t show up in the texture box. I uninstalled blender and then re-instaklled it, but it doesn’t seem be the virgin install as my custom interface is still there and the problem with the height map is too. If anyone can see anything wrong with the node configuration or anything else please tell me. I’m going start a thread asking how I can totally uninstall blender and then download it as a virgin download again starting from scratch. And then if import image as plane height map is working I’ll try this node configuration for the transparency again.

Hello.
I recently saw this in Blendernation:

There also explains what to do when the background is black.

Thanks YAFU. I’ve now totally reinstalled blender. The node configuration in the article is the same as Breaghas and it still doesn’t work. If I disconnect the texture alpha from the mix shader frac and I move the fray slider I can make the whole image transparent so the mix shader and transparency is working. It’s just the texture alpha channel that isn’t masking the alpha. I’m on windows 10, blender 2.76. Is everyone else using 2.76. Could this be a bug that isn’t in the previous blender version?


In another thread, I think someone suggested turning up the transmission bounces in Light Paths in the Render tab. I think the default is 12 or something like that… Not sure if it’s the same in your case…

Also - if your alpha channel is broken in the image, you might try dragging from the colour output of the image texture to the fac instead of using the alpha output… See if that changes anything…

Please, share the .blend file as IkariShinji suggested. If you do not want to share all your scene, remove what you do not want to share leaving only the parts with which you are having problems. Remember to pack the textures within the .blend (External Data > Pack all into .blend - Then save the file with a different name).

In cycles there are some problems with transparency in the viewport when the image has a background instead of alpha, but it should work well in rendering.

Edit:
I ask just in case. When you export the image as PNG in GIMP, you have unchecked the “save background color” option, right?

OK I’m new and didn’t know how I could share the blend file. It’s just a test file with the tree in it.

I imported the same image onto a plane again and when I went into node viewI have quite different set of nodes in the pallet. There are no shaders, they look different too. But when I opened the file I saved as Breaghas configuration the nodes are as they were. Are there 2 different sets of node pallets?

For packing the images into the .blend file:
https://www.blender.org/manual/data_system/introduction.html

Save the file in Blender and chosse it from PasteAll:
http://pasteall.org/blend/

and when you click “Upload File” and when it completes the upload, you share that new pasteall link you have.

Anyway, you tell me if the following image works with your node configuration:

http://www.blenderartists.org/forum/showthread.php?322623-How-to-ask-questions-effectively-on-blenderartists-org-support-forum

Thanks very much for the on going help!!

I’ve done it!!! :slight_smile: It doesn’t work if you import an image as a plane. I used the Sketchup importer plugin to import a plane I already painted with an alpha image in sketchup. And then I used this node configuration. It’s the node configuration the import image as plane is supposed to create but doesn’t and was at the end of a video on import image as plane.


I replaced the emitter with a defuse because I’m doing trees and vegetation and the object glowed in the dark :slight_smile: If anyone comes to this thread after searching the problem who doesn’t use sketchup. The node configuration I think should work if you associate the image with the plane in the traditional way. Something I’m not quite sure how to do yet. But if you can do it, the node configuration might be a solve.

Great you figured it out ^^

Well, more like fell over the answer backwards, but yeah :slight_smile: