This normal will not be flipped 🥲

First post, thank you for reading!

Attached is a screenshot of what happens when I try to extrude an image imported as a mesh.

I just import the image, loop cut it and extrude, but I always get this weird transparency. I’ve tried turning off x-ray, flipping normals, creating new files from zero, loading factory settings, even reinstalling Blender but no luck.

I’m sure I’ve missed something very basic but can’t figure out what it is.

Can anyone help me? Thanks!

It’s because when you imported your image you had selected “alpha” then Blender created a material with your texture connected to the base color and the alpha sockets.

So, to fix that in EEVEE you need to disconnect the texture from the alpha and go to material settings and set the blend mode to “opaque”.

In Cycles you just need to disconnect the texture from the alpha socket of the principled node.

1 Like

Thanks for the quick answer! That did the trick!

I re-imported the image unchecking Use alpha and set blend mode to opaque in the material tab.

So helpful, thank you!

1 Like

I am glad I could help. :slight_smile:
You are welcome.

1 Like