This... this can't be right, can it?

Sorry for the vague title, but I’m kinda stumped here. I’m doing some animation, and a LOT of what seems to be issues with Blender’s graph editor are popping up! First, I was confused that when I rotate something 90 degrees, the graph shows 0.00000024 degrees. I just assumed that I had missed something, even when continual rotation, perfectly visible in the 3D view, produces a flat line in the graph editor?
What really hit me like a punch in the gut was when I selected all points in thee graph and clicked to switch from Bezier interpolation to Linear. Only one switched. PLEASE tell me I screwed up somehow! This cannot be real, that Blender can’t handle multiple selected points switching interpolation in one click! This is going to HAUNT me in many scenes, switching back and forth! It’s my old nemesis in a new form, not being able to apply a material to multiple objects simultaneously. I know it’s no problem for regular use, but I’m doing some slightly irregular stuff (just large animations, really), and this nitpicking to repeat such grunt work feels like I’m back in the 90s doing stuff by hand. I’m gonna cry if this is my fate…
I use 2.79b, btw, but still hope this is some blunder by me, not some hole in the Blender toolseet :’(

No, it’s not right.

Rotation values depend on rotation mode (set in properties/object/transform) but if you rotate in the X axis 90 degrees and keyframe rotation, your X Euler rotation will be 90.

Whether that looks like a flat line is going to depend on the scale of the Y axis in your graph editor. If you can see from 0 to 10000, that will look very much like a flat line. If you can only see from 0 to 90, it won’t.

And if you select all in graph editor and set interpolation via key->interpolation mode->linear, it will set all graphs to linear. I just tested it in 2.79b.

No, it said Euler, and the values listed were miniscule, even though the 3D view showed normal rotation. It’s rendering now but I will upload images later, unless some solution shows up in the meantime…

Not look like, was. I checked the values, they were unchanging. Points showed up where I set keyframes, but the values were a perfectly flat line.

Is that the small selection in the panel, with the little icon? Because using that only changes one. I tried multiple times.

Edit: Reading my own post, I notice that I sound contrarian. I’m not trying to be, but what you describe simply seems to not be what I get. I don’t know why. As stated, I’ll see about getting screenshots when I can poke at things securely again…

I’m using the menu bar in the graph editor view.

Can you use the space bar to select multiple that’s what I did for rigid body I used the space bar and added the rigid body to multiple objects with an active object

And do you have an active object when you try to add to mutiple objects to it your active object will be yellow while everything else will be orange

The render is done so I tried things out a bit. The weird degree problem has vanished for now, not sure why, but no, I still cannot apply interpolations to more than one at a time. I select everything and set the interpolation to Linear…

… but all but one remain Bezier…

Those pictures are weird. For one thing, you only have a single channel selected. For another, it didn’t even change a single channel to linear, from what I can see. Plus, difference in graph scale.

Here are the exact steps I’m taking to set interpolation to linear for multiple channels:

  1. Lock all channels you don’t want to change, by clicking on the lock icon on the left.
  2. With your mouse in the graph editor, hit ‘a’ to select all.
  3. From the graph editor menu, select key->interpolation mode->linear.

Here’s what I get when I do that:

Notice that all channels are linear, except the channel I locked.

It’s okay to use spacebar menu search instead of the menu, I checked that. I’m afraid I don’t know what “the small selection in the panel with the little icon” is.

Again, this is in 2.79b. I suppose its not impossible that there are some user preferences or something that would lead to you and I getting different behavior. If that’s the case, sorry, dunno what to tell you.

Edit: also tested with multiple cubes, in case that was your problem. Nope, that works fine too.

Weird as in “they look unlike what you get”? That might indicate some setting problem. I isolated one channel for simplicity, removing a mess of lines. The first point is linear, but being flat, the line doesn’t really show it.

Same here. Unless… what do you mean by “graph editor menu”? I used the panel you see, with the scroll button thingie. Is the menu something else?

The menu bar-- view, select, marker, channel, key. Or else hit spacebar and type “set keyframe interpolation”.

I’ll try it out at the next opportune moment. Maybe they just forgot to put the same code in the popdown thing…

Just checked it out, and YES, when using thee menu it switches all of them, THANK YOU for that tip!! I alsso noticed that the dropdown menu (I finally remembered what those things are called) has “Active Keyframe” labeled over it, quite a hint. It still makes my head spin that the exact same function with such small, but essential, variation is located two completely different places, with no hint one way or the other. Blender still seems to drag around a few ghosts from the past regarding the learning curve… But it now does my bidding! For now…