three lights

if i have more than two lights in a scene with glsl enabled then every object in the scene goes black (my graphics card does support glsl) please help

Never happened to me, is it just in one blend, or every blend file you try?

EDIT: heh my bad, i read your question to fast >_>

Ummm…read carefully lipsonfire.

When does your scene go black? In the 3D view? Or only when you start the game?

3d view is when it goes black and as soon as i add the third camera the object goes black

Hmmm. Very strange. What type of lamps are you using?

just regular lamps but if i turn specular off it seems to work fine

did you try messing with your GLSL settings? they can be found in the game menu. (in the User preferences header)

yes i have nothing happened

when i right click (select) on the object it tuns pink

that means that your images are not packed and blender cannot find them…

no thats not the problem

hmmm post a blend. that would be easier.

I had a weird lamp problem this days, I use two lamps, one sun and one hemi light, the hemi has the no spec turned on and when i tryed to bake the scene, the image baked, instead of bake the shadow map it bakes a weird reflection of the objects in negative, i solve it removing the hemi light with no spec, i dont know if it will help you, good luck.
Ow Ow, i know that, I worked with an ATI graphic card and I had the same problem some months ago, the ATi have GLSL suport but it doesnt works very well on blender.

I have a Radeon 9550 256mb card i was having some problems with normal mapping in blender so i turned the 3d settings all the way up and now i have this problem

oh well its not like I’m going to be creating a whole game I will probably just stick to making models and textures and maybe even room demos. anyways thanks for the help guys.

I read somewhere that GLSL can only support 2 lights.

Hi billymuncher2,

Try to enable Adaptive AntiAlising and Temporal AntiAlising in Catalyst. Happened to me before. This link (registry setting) was my previous solution using ATI Tray Tools.

Let me know if it works for you.


i enabled Adaptive AntiAlising and Temporal AntiAlising but im not sure what you told me to do after that please explain?

i am also using Radeon 9600.