Three Point Arch Tool (v004 and 2.80 version 012)

Test it! Work solid as before! Thank you!

Three Point Arch Tool, version 001 released!

This update adds nice GUI with keyboard shortcuts and size information (heavily based off the GUI in NP Station). A Toolbar button button and preferences option were also added. The automatic pause in the last step were the number of arch segments could be changed was moved to a new pause menu activated with the spacebar.

Full changelog below:

New Features:

  • Added Tool panel shortcut
  • Added Help menu system based off NP Station
  • Pause / settings change option (spacebar) providing options to change number of arch segments and to navigate to different position in 3D View
  • Added option to pause menu to attempt to recover snap point to last starting point ®
  • Added on screen measurements
  • Added user preferences menu with options to change dipslayed measure ments, default number of arch segments, and whether extrudes are done after initial arch edge is created

Bug Fixes:

  • Fixed bug preventing unfinished arches from being deleted in certain circumstances
  • Face normals are now automatically recalculated after arch creation, no more need to manually flip normals

https://i.imgur.com/jhxBzRR.gif

Woo - hoo, a nice implementation :slight_smile:

It behaves nice, i see there are some new procedures you included. Congrats!

There are some things that could be polished here and there, i could give a few suggestions when i snag some time. Maybe you could copy the gif from the first post to your announcement post, to display the enhancements you made. Overall, a long missed feature :slight_smile:

Hey Okavango!

It took a while to get everything I added to work, but it’s finally much closer to being proper add-on than a proof-of-concept. :smiley: There were several more features I wanted to add, but I decided to leave them out of v001 release as it had already been over a month since the last release.

Three Point Arch Tool, version 0.0.3 and 2.80 version released!

Downloads

Note that there is no differences in terms of features between version 0.0.3 and the 280 version (0.1.1). The 280 version has a different number because of code changes that made it incompatible with the 2.7x versions of blender.

Changelog (0.0.1 to 0.0.3):

  • Fixed bug preventing arch from extruding in certain circumstances.
  • Fixed bug causing errors if the snap point was dragged offscreen
  • A lot of code cleanup

7 Likes

An update to the Three Point Arch Tool has been released, 0.1.2 (for 2.80) and 0.0.4 (for 2.7x)

The updates are on the same downloads page as usual.

This update is a bug fix to correct problems that were reported with the snapping code in 2.80, but, to play it safe, I back-ported the bug fix to the 2.79 version as well.

4 Likes

Hey there! this is great im loving it.

The thing is, it creates a single tab for the addon, and i want to include it in my own tab (which i made with the pie menu editor addon).

Is there a way to delete the tab “create”? Please?
Again, thank you a lot!!!

Thanks for updates

Not without editing the code (bl_category = 'Create'), but I can look into this for a future update

Doesnt work with 2.81 :frowning:

Hopefully this gets updated soon!!

Work perfect!
It would be great to have the ability to create only the first arc without further extrude, too!
Maybe with press SHIFT+Button?

ESC/Rclick before extrusion?

1 Like

Are you guys using 2.81 or 2.8? Addon doesnt load here.

When i press ESC or RClick before extrusion the first arc disappears…

@dream3
Unzip the download and change the blender version to 2.81 manually. It works!

It work on 2.83 today. It will be very cool to be have an option to just draw the 2D arch, plus an option to continue with another arch just like AutoCAD does. But I am happy with what you have made. Thanks you very much.

I found the ‘Enable extrude’ Button in the addon preferences!
But when it be disabled, the arc jumps out of axis constraint!

I am not having these issues locally. I just tested installing “three_point_arch_280_v012” with 2.81a and it worked without having to make any changes to the code.

You can have the tool exit after confirming the initial arch outline if you disable the “Enable Extrude” option in the add-on’s preferences. I’m not sure what you mean by “continue with another arch” here, do you mean go immediately have the tool start placing points for a new arch after one arch is completed?

Were you using the latest version? The axis jumping was a problem in a previous version, but this should be fixed in 012. I didn’t have this issue when testing (012) in 2.81a.

I refresh my Blender 2.81a version > now it works! Thx!
Maybe you can add the enable button for extrude to the panel?
Or all of the properties? …

I made a similar feature in NP_Station - a poly tool that extrudes automatically when you close the polyline. If you would like to keep just the 2D shape simply press escape while extruding and the operator reverts to last completed phase - 2D poly. If you would like to undo the whole poly simply press esc while in the first phase or delete afterwards. I found this procedure somewhat more convenient and faster than editing an addon preference (because of constant change) or making a separate tool. It works quite nice in practice.

In AutoCAD - when I draw the first Arch and hit enter it repeat the command and continue another arch at the last point you left off; I hope the images will explain it.

OPT-01

OPT-02

2 Likes