Tiling Issue Rendering With Cycles

Edit: Originally I thought this was in hybrid mode only, but I’ve now also seen it using only the GPUs

First off, I’m a software developer and not a 3D artist, so I apologize if I don’t come across clearly here.

I’ve been given a scene from a 3D artist and I’ve tried to render a machine that has two GPUs (RTX 2060 Super/RTX 2070) and 12 logical processors. I’ve noticed an issue sometimes where I see tiles are getting rendered differently. When rendering in hybrid mode (EDIT: this also happens using just the GPUs), it appears the two GPU threads race out ahead of the 10 CPU threads which makes sense. But one of the GPU threads appears to render its tiles very differently than the other. At least I think it’s one of the GPU threads, as the CPU threads that lag behind tend to render correctly. This is blender 2.8. I’m using a tile size of 32x32. If there’s any other relevant information I can provide let me know! Thanks in advance.


Looks like a bug to me. Does it happen with every render or just this file?

If it happens with every file you try, then report it. Worst thing that can happen is that they mark it as not-a-bug. :slight_smile:


Yeah, that should be a bug (or an obscure hardware issue on your system). You might try a 2.81 alpha nightly build and if the problem occurs there then submit a bug report (Help->Report a Bug) if you can submit a .blend that demonstrates the issue for you.

Does it happen with any render, or just specific scenes? If it happens a lot then maybe it’s more likely to be a hardware issue, just because I don’t think a lot of people are seeing problems like this, though I have seen one or two people with similar issues.

The only time I encountered this was when I tried to get an AMD and NVIDIA card working together under Linux. There was something with NVIDIA’s OpenCL implementation.
But that shouldn’t be the problem with your setup.