Tip for flickering Background in Blender 2.91

Hey all,

I was having this annoying background flickering of the viewport when I would use orthographic views. I tried to search the web for a solution and found some outdated ones suggesting turning the draw method to triple buffering, which I couldn’t find in the prefs for 2.91.

But after some fiddling around I found out it was G-Sync who was the culprit. I had it set to enable for windowed and full screen mode. I found if I turned it off or just set it to only fullscreen mode it went away, even when Blender was fullscreen. I had a hunch it might be a Nvida setting as Blender has always been rock solid for me and G-Sync is known to play doddgy with some games.

Just thought I’d share the tip incase anyone else was having this error.

Kind Regards,


1 Like