tips on highering fps rate

ok, so i created a game, and saved it as an exe, i turned it on and the fps rate was absolutly horrible! amazingly slow! there aren’t that many details, and the poly count is actually low! 1476 faces in the entire castle! (and it’s a pretty big one!)
i’m thinking that maybe it’s the textures or lighting or something…or maybe there is just an option to make the fps higher and i dont know where that is, any help would be appreciated, if you could contact me on icq i could send you the game and you’ll see how it is…

icq:347208181

so please help

You can change the setLogicTicRate… do some search about ticrate and I think it’ll give you some more info… I used this code in my testgames and it made it work very smoothly…

import GameLogic

GameLogic.setLogicTicRate(100)
GameLogic.setPhysicsTicrate(100)

hmmm…? where do i put that code? please be more specific i’m not a big pro in these things as you can see

guys, i really need help here, i dont understand why it is so slow! people here get 100fps in their games (much more detailed than mine) i get like…3. seriously! it’s that slow! (btw where can i see how much is it exactly?)

Get. a. better. computer.

Pro? neither am I… specially not concerning python and games! Let me try to explain how it works for me. First of all save the code (for example “Tic.py”), then load the text into the Blender text editor. Select your camera. In the button window go to the logic panel (pacman thingy or just press F4). Activate the “Actor” button. Add an “Always” sensor. Add a “Python” Controller. Type the name of the code behind Script: (in this example Tic.py and remember that Blender is case sensitive). Link the Sensor and the Controller (the 2 yellow dots). Play your game… and voila! That should be it! By default the ticrate is set to 100, you can tweak that as you will. I hope that was clear, good luck!

no…avtually it didnt really work…i dont really know how to save things with *.py ending

this is very weird…i enter “tic.py” under the script in contrrollers and when i press enter it disappears (hu?)

this is what i did manage to make…but still the fps remains the same
http://img207.imageshack.us/img207/9136/fail9cu.th.jpg

to save something with a .py ending go into notepad, type the code and select save as, under save as type click all files, type in the name of the file and then type .py on the end. assuming u have windows that is :slight_smile:

Hi.There may be other problems why your FPS is so slow.Maybe the castle has too many collision faces enabled,maybe its really the lighting(i heard that lighting is really slow on some PC’s).Try using as low texture res as possible.Is the game slow only in exe or is it in blender too.Maybe your exe has too big resolution or something.Check if the game doesnt have too much unneeded proceses running or if you have too much logic.Dont use too many armatured objects and dynamic objects.If all that stuff doesnt work then its probably your computer.

Bye

the entire scene:5633 ver, 5042 fra, 5 lights, no armatures, and my computer is pretty new…good, big games run smoothly on it (gta san andreas for example)

ok thanks to all of you, i think i found the problem, it seems that the fps is good when i’m facing a wall or something, but there is a specific object that slows it down, therefore i’ll try to change it’s texture and i beliave it will increase the fps, another question is: how do i make the textures slow it as less as possible?

thanks again, and goodbye

Well , thats strange.I have a high end and even on my computer Vice City runs kind of Laggy,but almost all the blender games run with a great FPS.Do the other Blender games run slow on your PC , check it out.If no , than its a problem with your .blend

it, is, i know it is…now i see that i really dont know how to work with textures in games (yup, i’m a noob), so i’ll play with it abit…thanks for your assistance, i really appreciate it

You can also remove the .txt tag in Blender by just clicking on the name. When you type “tic.py” while the file is called “tic.py.txt” it won’t find it… :wink: Also remember Blender is case sensitive… But looking at your screenshot it should work already I think… So only suggestions at this point I can make are:

  • rename to “tic.py”
  • put an # in front of “GameLogic.setPhysicsTicrate(100)”
  • host the .blend file so I can try what it does here

wow! am I being so slow?! lol I should change my own typeticrate! well good you found what is causing the slowdown in your game. On the texturing part it’s best to keep your textures as small as possible, think 256 x 256 is about the max to keep good performance. Think it’s also best is to use sizes like 8, 16, 32, 64 etc… But main thing is small is better… since graphicscards do mipmapping and antialiasing small pics give good results aswell… Oh, and using .jpg can be handy since they are small in bytesize, though when you need aphachannels you need to use .png or .tga

just looked at the texture files
jpeg
1)549 x 549 51.7 kb
2)223 x x256 23.9 kb

think that’s too big?

I would change the size of the 549x549 to 512x512 (as I stated before 2, 4, 8, 16, 32, 64 etc… most graphicscards seem to like that better so I was told), but if you can get it smaller the better. I suggest you to try 256x256 or 128x128 or 64x64 or even smaller… it’s quality versus framerate you set the priorities there. Personally I like a less slick game with a good framerate better than a very pretty game which has a framerate of 3 fps…

Oh… and you might want to check this:
https://blenderartists.org/forum/viewtopic.php?t=23900&highlight=fps

thanks, also i didn’t mention that in the uvmapping i enlarged the object so the texture appears on it…like…lots and lots of time (i’m guessing that’s the cause?)

Why don’t you post the blend file? Then we can check the fps on our machines…

Keith. 8)