To malefico and kino: I have knews about cinelerra.


(Timonides) #1

Back to that subject again :o .

I was trying to compile the latest backup source of cinellera and after a lot of trouble :-? , I manage to come up with only one compile error, related to ALSA. I tried almost everything I could think of, but that stupid error was so persistant… :x

Then frustrated, I decided to go back to the sourceforge site to check their forum, in case there was an answer to my problem and … voila!!!

They have released the first beta release (beta-1-1) and you know what… it’s an rpm!!! :smiley:

I am downloading this thing right now. When it’s finished I will try to install it and see!!!

I 'll come up with more news to the subject if you are still interested.

Cheers!!! :wink:


(malefico) #2

Did you upgrade manually to GCC 3.0x or did you upgrade your whole distro ?

AFAIK that ALSA problem can be solved if you edit the configure/Makefile to tell the compiler you DON’T have ALSA drivers installed.

I wouldn’t try the RPMs yet… always a lot of dependencies errors… too risky to hang my system installing it with -force and -nodeps.

Cheers.

Thanx for the info.

malefico.


(pannomatte) #3

I think I’m gonna try. Will keep you posted.
Daniel


(Timonides) #4

Hello guys.

I just upgraded manually to gcc-3.0. Also tried to disable ALSA from the global_config file, but it didn’t work (perhaps I missed something or did something wrongly). Haven’t tried yet to upgrade ALSA.

I have tried the rpm and I had this problem with failled dependencies. It’s really weird, because I have the “supposed” missing shared libraries. I don’t know, maybe it is looking for them in the wrong directory(!!!).

Anyway, I’ve installed it with --nodeps, and it seems to be working o.k. although I didn’t have the time to test the program properly.

I’ll keep you informed if I have any more knews on the subject…

P.S. I’ ve watched the game Argentina vs England and I can say that it was a real shame the way Argentina lost. Please someone stop this referee, he has done it before…


(kino) #5

Hi
just succesfull installed :slight_smile:
seem really stable, go to test :wink:

Kino


(Timonides) #6

Hello kino!!! :smiley:

I am confirming from what I’ve seen so far, cinelerra looks o.k. to me too :smiley: .

If it is possible for you, could you please inform us if you have found any difficulties during the installation (I mean the dependencies issue)?

By the way which distro are you running? Mine is SuSE 7.3.

Thanks in advance…


(pannomatte) #7

I think I have a sucsessfull rpm istall but I can’t seem to run it. I have an executable in /usr/bin/cinerella but it doesn;'t do anything. what am I doing wrong
thanks in advance
Daniel


(Timonides) #8

Hello pannomatte :smiley: .

In order to be able to help, you have to be more specific about, which distro are you running, if you have encountered any problems during installation (missing libraries) etc.

If you had a succesfull install you should be able to invoke the program, by issuing “cinelerra”, from the console. This may sound stupid to you… but I have to ask (because these things do happen some time), are you spelling this correct? Because I see from your post that you are writng “cinerella”, which is wrong.

Anyway I’ll be waiting for your feedback.

Always, glad to help a fellow…[/u]


(pannomatte) #9

I have an executable in usr/bin/cinelerra. If I try to run it from a console window I get :
error while loading shared libraries: libstdc++.so.3: cannont open shared object file: No such file or directory.
Found the library but not rtivial to icompile
Running Red Had 7.2 750mhz CyrixII 384 mb ram NVidia TNT2 pci. :-(. Should I uninstall and not use package manager? Tried to install with the following as suggested but it didn’t go.
rpm -i --force --nodeps cinelerra-beta1-1.i686.rpm (tried 386 as well). Any help greatly apreciated. Thanks.
Daniel


(Timonides) #10

Hello pannomatte :smiley: !

o.k. I am running SuSE 7.3 which is not different from your Redhat 7.2.

From the information that you give me I have to assume that you don’t have gcc-3.0 installed. I think that libstdc++.so.3 is provided by gcc-3.0, or later, and if you install it, your problem might be solved.

So my suggestion is this: first uninstall cinelerra, then compile and install gcc-3.x (preferably under /usr, not /usr/local) and finally install cinelerra again with the --nodeps option.

Please tell me if you have any success with that…

Bye for now…


(pannomatte) #11

Got it thanks. Turned out everything I needed was on the RedHat 7.2 2nd install disk in RPM! Just loaded up the unsatisfied dependencies via package manager and voilla. Painless. (In retrospect) Now lets see what this thing can do. Will keep you posted. Thanks Again
Daniel


(Timonides) #12

Hello again :smiley: !

That’s really good news pannomatte.

I hope you’ll enjoy it as much as I do. I think that cinelerra is not bcast2k
successor, after all. I think it is bcast2k with an other gui. What is your opinion?

Really glad that you made it, have fun…


(pannomatte) #13

I’m just now getting around to looking at them both but it appears Bcast2000 has been removed from evan the souceforge site. Have you had any experiance with the renderfarm capabilities? And looks like it’s limited to what files it can import. No AVI raw or TGA ? And NO documentation…Ah the learning curve.
What is DVD resolution, and whats the best authoring format In your opinion.
D


(Timonides) #14

Hello pannomatte :smiley: !

It is true that cinelerra has a limited import file format support. As it’s predecessor bcast2k, it can only load JPEG, JPEG images lists and quicktime .mov files. But then again this is the case with almost all video editing programs in Linux in general. Cinelerra has a better export file format support, than bcast, at least from what I have seen untill now, including JPEG, TGA, TIFF, MPEG, AVI, QUICKTIME etc.

I haven’t heard about renderfarm till now, I will check it and tell you. It seems promising.

As for documentation, since cinelerra is identical to bcast2k, you can use bcast’s documentation, for it.

Malefico, had once a very good tutorial on making movies with Blender and bcast2000 and I think it is still there at his web page. I followed his instructions and made a small video clip with cinelerra in seconds(cinelerra works exactly as bcast2k).

Check it out:

                      http://malefico.netfirms.com/tutor/audiovideo-en.html

You can find there instructions, links for documentation on bcast2k and also a hacked version of broadcast 2000, that supports even DivX encoding. DivX by the way, is a really interesting case as an authoring format although you could also check bink from radtools.

I can even send you a copy of my SuSE 7.3 handbook by e-mail next week (I 'll be on vacation for a week) if you like. It has a chapter about audio editing with bcast2k.

That’s all I can think of by now. The rest I am in the learning process also. I 'm waiting to hear from you, bye…


(pannomatte) #15

Thats a great resource thanks. Right now I’m trying to set up Samba and get my network tuned up a bit, what a pain. The goal being is I want to get into renderfarming Blender as well as Ceinelerra. I read in the open discusion forum about dual process support for Cinelerra and the comment came back that it was more efficient to use it in Renderfarm mode. So apparently it will distribute the sesion as well. Hmmmm.
http://sourceforge.net/forum/forum.php?thread_id=691394&forum_id=42723

http://sourceforge.net/forum/forum.php?thread_id=693437&forum_id=42723

Daniel