To[o] many transitions, is this a natural image?


(soletread) #1

This message comes up often when using image maps. Found some details on a foreign website but the translation was tough to figure…

Is it possible the image maps are too big? Pixel size? Mine are 512 x 512, TGA images.

“Aborting antialiasing” is the next part of the message. Would explain my the render looks jaggy…

Is this a bug or am I not playing by the rules…?

This error has come up on JPG files also.


(S68) #2

Mmmm… isn’t this forum more appropriate?

Stefano


(soletread) #3

Ayep! Certainly much easier to understand.

Philosophy: Try first, ask last. :o


(eeshlo) #4

The ‘Anti’ button is meant for cartoon type images, or at least images that use only a few colors, a natural image (ie. a photograph) uses much more, which is why you get that error. For this to work properly, the image type should be one that does not use any kind of lossy compression (like jpeg). For general anti-aliasing you need to enable the OSA button. By enabling motionblur as well you can improve the AA further.


(soletread) #5

Oh right, I understand.

So the ‘Anti’ button shouldn’t be used with TGA pics? Just stick to OSA?

I kind of misinterpreted the message as saying: “You need to be using a natural image” where it is in actual fact saying “You’re using a natural image aren’t you?”

If an image is used as a texture, that image will then be stretched to the size of the mesh? Does it get stretched or resized? I am asking because if you stretch an image it loses definition but if you resize, it doesn’t (well not as noticeable). The best way theoretically to get the sharpest most real to life looking texture would be to ensure it was on a perfectly sized mesh.

I was under the impression that the ‘Anti’ button could minimise the type of ‘blur’ that comes from stretching.


(RipSting) #6

I was under the impression that the ‘Anti’ button could minimise the type of ‘blur’ that comes from stretching.

Blender pre-blurs all textures so that the final image doesn’t look pixelated if you use a low-res image. To have Blender not do this, turn down the “Filter” property to 0.


(soletread) #7

Fantastic! Thanks. :smiley: