Too big to render

i made a model which, if rendered using standard settings, my computer cant handle.
ive seen far more complex things made than mine, so i was wondering, how can i make things managable?
btw, i have a 2.2 Ghz Pentium DualCore, a 8800Mhz vidcard and 4 Gb of Ram
heres the blend file:
http://www.savefile.com/files/1845722
feel free to render it for me if you like:evilgrin:

mTm

Have you tried increasing Xparts and Yparts? I hear that makes blender use less memory.

Go through the parts and remove doubles.
Render it in layers, and only render the visible parts.

4,000,000 is a lot of vertices.

You have 4GB of RAM!? I have 1 GB; I envy you.

What OS are you on? Windows? Linux? Unix?

If it is Windows, then this may interest you:
http://mikepan.homeip.net/blendermemory

Hi,

I messed around with your file a bit:

http://www.savefile.com/files/1846042

And I produced a couple of renders. One is the full body shot that you set up, with ray tracing. The closer one is a scanline render with approx. ambient occlusion.

Your model was quite polygon heavy and used a lot of subsurf. Some areas had uneven distributions of vertices, e.g. the pipes had a lot of vertices defining the cross section, but very few defining the curve of the pipe, so adding subsurf was necessary to smooth the curve, but added a lot of extra vertices around the pipe.

I reduced the amount of subsurf on most of your objects, or removed it completely if it didn’t make a significant amount of difference. I added the edgesplit modifier to everything, to bring out the details. Stupidly, I applied the mirror modifiers you had on everything (I don’t know why I did that!). Some of your objects had doubles, so I removed them.

Hope this helps.

[edited to change pngs to jpgs]

Attachments



i am using layers, but i never had any better results because of it, except while editing

thanks for the effort, finally i can see a complete render :smiley:
BTW, what does the edgesplit modifier do?
thanks for the help,
mTm

I’ve rendered images that big with Blender before, usually if you have Windows you may need Blender built with the LAA or ‘large address aware’ flag

Hi,

http://wiki.blender.org/index.php/Manual/EdgeSplit_Modifier

No problem, glad I could help.