Too much force = through walls???

Hey- when you add too much force to an object it just goes right through walls- how do you get around this so it stops when it hits the wall and doesn’t just rocket through them? EXAMPLE: just make a cube with a 100 force head straight into a wall, it’ll just go straight through the wall…

The Blender game engine is not known for high-speed collisions. Plus, 100 force is wayyyyyyyyy too much for any game engine to handle. You must reduce the amount of force you use.

or use 2.25. it lacks some new features but you rarely have this problem.

or use 2.25. it lacks some new features but you rarely have this problem.

Isn’t the only reason it has better collisions is because it has the “Solid Collision Library”? I think it was remove in all the versons after 2.25 because the original creator of the Solid Collision Library didn’t want this stuff open source or somethink like that.

I wish we had our Solid Collision Library back.

I have noticed that high-speed objects go through more when they are smaller, have less mass, and are going perpendicular to the other object.

You can also try Ctrl-A (set scale & rotation) on your dynamic object AND your target object, that sometimes helps. You might also try changing those objects bounds to Convex Hull Polytopes type, then Ctrl A again.
Also be aware that high velocities and low frame rates can cause moving objects to seem to pass thru solids (or other dynamics, for that matter). You might see a difference if you just Enable All Frames in the Game Menu, but it WILL slow the general fps to compensate.


Thanks for all the tips- Lefty the enable all frames really helped out the overall game look and it helped bouncing a little- the best thing I found to do was just select everything with (A) and then scale it down by 90%, then scale all your forces down by 90% too- since a smaller force on a smaller object is the same as a large force on a large object, only now the game engine doesn’t hate me :wink:

Well done! Looking forward to see what you come up with!!!


Also, try using linV. I think its more reliable than Dloc ( I’m not sure since I’m using .25 at the moment and am too lazy to check if it works myself :p)

the problem as I see it is if the object covers more ground than it’s width, it has the ability to pass through objects. Example:
Cube A is 1 BU on all sides. it has a force applied on it that is great enough to move it, say, 2 BU per frame (force/mass=acceleration- so if it’s mass=1, force=acceleration). The engine calculates collisions where it ends up, but if there’s a flat (or just thin) wall in the 1 meter space between it’s start and end points, it’s never detected.
Basically, I ration out speed to make sure there’s no space between an object’s start and end positions. if an object is 1 BU long, I never let it move more than 1 BU per frame.

I rambled a bit, but I hope I got my point through the mess of sleepy wordiness.