Toon Shader with flat white background?

I kind of understand the toon shader but Im having a few issues. I would like this to be a flat white background with bright orange K objects.
(It would be also be cool if I could control the toon shading colors of the K with the color ramp but that would just be a bonus)

  1. The main issue is that the World Background is set to white but I cant make it render as white (unless I raise the strength, which also alters the color of my objects).
  2. I am trying to control the orange toon shader colors by using a ColorRamp + AO as I have seen online.
  3. I would love if all of this would be accurately viewable via the EEVEE preview camera view, but is that not possible? (which if not is fine)
  4. The Ks arent as orange as the bright orange in the toonshader color. Maybe this has to do with what is causing the background to be gray instead of black?

Ks.blend (832.5 KB)

I think this solves your issues:

Ks-fixed.blend (822.2 KB)

When you are doing cartoon style renders, it is a good idea to use the old default color management instead of filmic, because flimic keeps white materials from appearing pure white. It’s really good for photo-realistic stuff, but when you are doing non-physically correct renders, it can get in the way.

You can also have the camera see a different background from the one that is actually influencing the shading of your materials. Just look at the world shader I setup in the corrected file.

Oh, and I recommend previewing using cycles if you plan to render in cycles when you are done. The end goal for eevee is to have an accurate preview for what could be a cycles scene in the end, but atm it still doesn’t match cycles. The settings for lamps are too different, and lighting still has to be adjusted when you set the renderer to cycles.

Awesome! All that helps a lot, thank you for showing me.
I have been learning Blender for a long time and was not aware of the Filmic option.

My only question i have left is: why are the renders a full realistic render still? I am trying to get the “K” objects to just be two shades of orange (well, orange as one shade and brown as the dark shade). I now moved my colorRamp colors to not have any in-between gradients, and have the colors flat-out meet eachother (orange position up right against brown in the ColorRamp), but that color ramp doesnt seem to be affecting the render.

I am going more for something like this:


Yeah, filmic is relatively new in blender.

Oh. If that is what you want, then it’s best to use an emission shader (the type used for lights) instead of a regular material. When you do npr stuff, you often need to control the shading on the object itself, and the only way to get something like a “shadeless” material is to use the emission shader (you can use the light path node to keep the object from shining light on regular materials if necessary). That makes it so that the lights in the scene don’t affect the shading, but you will have to use tricks to produce the shading you want.

The AO node simulates the darkening effect that is seen inside the cracks and folds of objects, so I don’t think you’ll get the type of shading you want using it. You can see where the brown shows up when using the AO node on this object in this screenshot:

Eevee has a shader converter that cycles doesn’t support atm which is good for this type of thing. It turns the final output of a shader into a color which can be adjusted with a color ramp:

Ks-fixed2.blend (752.3 KB)

The lighting in your scene will affect the final look when you use eevee’s shader to rgb node, but you can adjust that look with a color ramp, and plug it into an emission shader to get the level of control you need when doing this sort of thing.

awesome thanks for all that help i really appreciate it!!